summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2008-05-13 00:10:45 +0000
committerMatteo Croce <rootkit85@yahoo.it>2008-05-13 00:10:45 +0000
commit2058b8096491f4976710ecbd1d70d82c4ffaae13 (patch)
tree44147cf5f33a794e33e03536210590522f61b077 /target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
parent06c7c0428831969f02dcb5585edb859cf7025640 (diff)
downloadmaster-31e0f0ae-2058b8096491f4976710ecbd1d70d82c4ffaae13.tar.gz
master-31e0f0ae-2058b8096491f4976710ecbd1d70d82c4ffaae13.tar.bz2
master-31e0f0ae-2058b8096491f4976710ecbd1d70d82c4ffaae13.zip
atheros: added marvell switch driver
SVN-Revision: 11129
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch b/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
new file mode 100644
index 0000000000..1adcf0d411
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
@@ -0,0 +1,54 @@
+Index: linux-2.6.25.1/drivers/net/phy/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/Kconfig 2008-05-12 23:44:33.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/Kconfig 2008-05-12 23:45:33.000000000 +0200
+@@ -70,6 +70,12 @@
+ ---help---
+ Currently supports the ADM6996F switch
+
++config MVSWITCH_PHY
++ tristate "Driver for Marvell switches"
++ select VLAN_8021Q
++ ---help---
++ Currently supports the Marvell 88E6060 switch.
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+Index: linux-2.6.25.1/drivers/net/phy/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/Makefile 2008-05-12 23:44:50.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/Makefile 2008-05-12 23:45:59.000000000 +0200
+@@ -13,6 +13,7 @@
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+Index: linux-2.6.25.1/drivers/net/phy/mdio_bus.c
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/mdio_bus.c 2008-05-12 23:44:21.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/mdio_bus.c 2008-05-12 23:45:33.000000000 +0200
+@@ -35,6 +35,12 @@
+ #include <asm/irq.h>
+ #include <asm/uaccess.h>
+
++static void mdio_dev_release(struct device *dev)
++{
++ /* nothing to do */
++}
++
++
+ /**
+ * mdiobus_register - bring up all the PHYs on a given bus and attach them to bus
+ * @bus: target mii_bus
+@@ -85,6 +91,7 @@
+
+ phydev->dev.parent = bus->dev;
+ phydev->dev.bus = &mdio_bus_type;
++ phydev->dev.release = mdio_dev_release;
+ snprintf(phydev->dev.bus_id, BUS_ID_SIZE, PHY_ID_FMT, bus->id, i);
+
+ phydev->bus = bus;