summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
commit08dc68c9dfd506c35d00c09156ec898bc18d1409 (patch)
tree5e60a5f19e831312d49d68ad7dc237fbeb86280a /target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
parentac5cfeb41720bfc0ac9781462cb0b1b1547b3f9d (diff)
downloadmaster-31e0f0ae-08dc68c9dfd506c35d00c09156ec898bc18d1409.tar.gz
master-31e0f0ae-08dc68c9dfd506c35d00c09156ec898bc18d1409.tar.bz2
master-31e0f0ae-08dc68c9dfd506c35d00c09156ec898bc18d1409.zip
add proper 2.6.25 support
SVN-Revision: 10865
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..780fd34a5c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
@@ -0,0 +1,22 @@
+Index: linux-2.6.23-rc9/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/leds/Kconfig 2007-10-02 12:51:05.000000000 +0800
++++ linux-2.6.23-rc9/drivers/leds/Kconfig 2007-10-03 23:43:31.000000000 +0800
+@@ -133,4 +133,8 @@
+ load average.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+Index: linux-2.6.23-rc9/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/leds/Makefile 2007-10-02 12:51:05.000000000 +0800
++++ linux-2.6.23-rc9/drivers/leds/Makefile 2007-10-03 23:42:24.000000000 +0800
+@@ -22,3 +22,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o