summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:26:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:26:43 +0000
commit4503efda2da6e5868bbbd274c042622dc03edd8e (patch)
tree3678d3fa5a554dcf4f4295ab9dcb5ab026240683 /target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch
parente582f614b6e15517a9207b0a96a72b68f7a254df (diff)
downloadmaster-31e0f0ae-4503efda2da6e5868bbbd274c042622dc03edd8e.tar.gz
master-31e0f0ae-4503efda2da6e5868bbbd274c042622dc03edd8e.tar.bz2
master-31e0f0ae-4503efda2da6e5868bbbd274c042622dc03edd8e.zip
refresh generic 2.6.25 patches
SVN-Revision: 11189
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch54
1 files changed, 27 insertions, 27 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch b/target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch
index 695c6c0ecc..66fa504a8c 100644
--- a/target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/100-netfilter_layer7_2.17.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.25.1/net/netfilter/Kconfig
+Index: linux-2.6.25.4/net/netfilter/Kconfig
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/Kconfig
-+++ linux-2.6.25.1/net/netfilter/Kconfig
+--- linux-2.6.25.4.orig/net/netfilter/Kconfig
++++ linux-2.6.25.4/net/netfilter/Kconfig
@@ -735,6 +735,27 @@ config NETFILTER_XT_MATCH_STATE
To compile it as a module, choose M here. If unsure, say N.
@@ -30,10 +30,10 @@ Index: linux-2.6.25.1/net/netfilter/Kconfig
config NETFILTER_XT_MATCH_STATISTIC
tristate '"statistic" match support'
depends on NETFILTER_XTABLES
-Index: linux-2.6.25.1/net/netfilter/Makefile
+Index: linux-2.6.25.4/net/netfilter/Makefile
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/Makefile
-+++ linux-2.6.25.1/net/netfilter/Makefile
+--- linux-2.6.25.4.orig/net/netfilter/Makefile
++++ linux-2.6.25.4/net/netfilter/Makefile
@@ -77,6 +77,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RATEEST)
obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
@@ -42,10 +42,10 @@ Index: linux-2.6.25.1/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_MATCH_STATISTIC) += xt_statistic.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STRING) += xt_string.o
obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
-Index: linux-2.6.25.1/net/netfilter/xt_layer7.c
+Index: linux-2.6.25.4/net/netfilter/xt_layer7.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/xt_layer7.c
++++ linux-2.6.25.4/net/netfilter/xt_layer7.c
@@ -0,0 +1,634 @@
+/*
+ Kernel module to match application layer (OSI layer 7) data in connections.
@@ -681,10 +681,10 @@ Index: linux-2.6.25.1/net/netfilter/xt_layer7.c
+
+module_init(xt_layer7_init);
+module_exit(xt_layer7_fini);
-Index: linux-2.6.25.1/net/netfilter/regexp/regexp.c
+Index: linux-2.6.25.4/net/netfilter/regexp/regexp.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/regexp/regexp.c
++++ linux-2.6.25.4/net/netfilter/regexp/regexp.c
@@ -0,0 +1,1197 @@
+/*
+ * regcomp and regexec -- regsub and regerror are elsewhere
@@ -1883,10 +1883,10 @@ Index: linux-2.6.25.1/net/netfilter/regexp/regexp.c
+#endif
+
+
-Index: linux-2.6.25.1/net/netfilter/regexp/regexp.h
+Index: linux-2.6.25.4/net/netfilter/regexp/regexp.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/regexp/regexp.h
++++ linux-2.6.25.4/net/netfilter/regexp/regexp.h
@@ -0,0 +1,41 @@
+/*
+ * Definitions etc. for regexp(3) routines.
@@ -1929,20 +1929,20 @@ Index: linux-2.6.25.1/net/netfilter/regexp/regexp.h
+void regerror(char *s);
+
+#endif
-Index: linux-2.6.25.1/net/netfilter/regexp/regmagic.h
+Index: linux-2.6.25.4/net/netfilter/regexp/regmagic.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/regexp/regmagic.h
++++ linux-2.6.25.4/net/netfilter/regexp/regmagic.h
@@ -0,0 +1,5 @@
+/*
+ * The first byte of the regexp internal "program" is actually this magic
+ * number; the start node begins in the second byte.
+ */
+#define MAGIC 0234
-Index: linux-2.6.25.1/net/netfilter/regexp/regsub.c
+Index: linux-2.6.25.4/net/netfilter/regexp/regsub.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/regexp/regsub.c
++++ linux-2.6.25.4/net/netfilter/regexp/regsub.c
@@ -0,0 +1,95 @@
+/*
+ * regsub
@@ -2039,10 +2039,10 @@ Index: linux-2.6.25.1/net/netfilter/regexp/regsub.c
+ }
+ *dst++ = '\0';
+}
-Index: linux-2.6.25.1/net/netfilter/nf_conntrack_core.c
+Index: linux-2.6.25.4/net/netfilter/nf_conntrack_core.c
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/nf_conntrack_core.c
-+++ linux-2.6.25.1/net/netfilter/nf_conntrack_core.c
+--- linux-2.6.25.4.orig/net/netfilter/nf_conntrack_core.c
++++ linux-2.6.25.4/net/netfilter/nf_conntrack_core.c
@@ -210,6 +210,14 @@ destroy_conntrack(struct nf_conntrack *n
* too. */
nf_ct_remove_expectations(ct);
@@ -2058,10 +2058,10 @@ Index: linux-2.6.25.1/net/netfilter/nf_conntrack_core.c
/* We overload first tuple to link into unconfirmed list. */
if (!nf_ct_is_confirmed(ct)) {
BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
-Index: linux-2.6.25.1/net/netfilter/nf_conntrack_standalone.c
+Index: linux-2.6.25.4/net/netfilter/nf_conntrack_standalone.c
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/nf_conntrack_standalone.c
-+++ linux-2.6.25.1/net/netfilter/nf_conntrack_standalone.c
+--- linux-2.6.25.4.orig/net/netfilter/nf_conntrack_standalone.c
++++ linux-2.6.25.4/net/netfilter/nf_conntrack_standalone.c
@@ -181,7 +181,12 @@ static int ct_seq_show(struct seq_file *
return -ENOSPC;
#endif
@@ -2076,10 +2076,10 @@ Index: linux-2.6.25.1/net/netfilter/nf_conntrack_standalone.c
return -ENOSPC;
return 0;
-Index: linux-2.6.25.1/include/net/netfilter/nf_conntrack.h
+Index: linux-2.6.25.4/include/net/netfilter/nf_conntrack.h
===================================================================
---- linux-2.6.25.1.orig/include/net/netfilter/nf_conntrack.h
-+++ linux-2.6.25.1/include/net/netfilter/nf_conntrack.h
+--- linux-2.6.25.4.orig/include/net/netfilter/nf_conntrack.h
++++ linux-2.6.25.4/include/net/netfilter/nf_conntrack.h
@@ -124,6 +124,22 @@ struct nf_conn
u_int32_t secmark;
#endif
@@ -2103,10 +2103,10 @@ Index: linux-2.6.25.1/include/net/netfilter/nf_conntrack.h
/* Storage reserved for other modules: */
union nf_conntrack_proto proto;
-Index: linux-2.6.25.1/include/linux/netfilter/xt_layer7.h
+Index: linux-2.6.25.4/include/linux/netfilter/xt_layer7.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter/xt_layer7.h
++++ linux-2.6.25.4/include/linux/netfilter/xt_layer7.h
@@ -0,0 +1,13 @@
+#ifndef _XT_LAYER7_H
+#define _XT_LAYER7_H