summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/010-disable_old_squashfs_compatibility.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
commit08dc68c9dfd506c35d00c09156ec898bc18d1409 (patch)
tree5e60a5f19e831312d49d68ad7dc237fbeb86280a /target/linux/generic-2.6/patches-2.6.25/010-disable_old_squashfs_compatibility.patch
parentac5cfeb41720bfc0ac9781462cb0b1b1547b3f9d (diff)
downloadmaster-31e0f0ae-08dc68c9dfd506c35d00c09156ec898bc18d1409.tar.gz
master-31e0f0ae-08dc68c9dfd506c35d00c09156ec898bc18d1409.tar.bz2
master-31e0f0ae-08dc68c9dfd506c35d00c09156ec898bc18d1409.zip
add proper 2.6.25 support
SVN-Revision: 10865
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/010-disable_old_squashfs_compatibility.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/010-disable_old_squashfs_compatibility.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/010-disable_old_squashfs_compatibility.patch b/target/linux/generic-2.6/patches-2.6.25/010-disable_old_squashfs_compatibility.patch
new file mode 100644
index 0000000000..99c5e2ec33
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/010-disable_old_squashfs_compatibility.patch
@@ -0,0 +1,23 @@
+Index: linux-2.6.23-rc6/fs/squashfs/Makefile
+===================================================================
+--- linux-2.6.23-rc6.orig/fs/squashfs/Makefile 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23-rc6/fs/squashfs/Makefile 2007-09-21 16:23:58.000000000 +0800
+@@ -4,4 +4,3 @@
+
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+Index: linux-2.6.23-rc6/fs/squashfs/squashfs.h
+===================================================================
+--- linux-2.6.23-rc6.orig/fs/squashfs/squashfs.h 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23-rc6/fs/squashfs/squashfs.h 2007-09-21 16:23:58.000000000 +0800
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)