summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-02 10:17:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-02 10:17:03 +0000
commitd7d8665572aea1b814c4a59d1b25d4a41c3baa62 (patch)
treee5ff9d6b5df84b7ab7808e1cfd9e0261db5bc4ce /target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
parentaaac1064de71c495d284b981d83f70d3bd445826 (diff)
downloadmaster-31e0f0ae-d7d8665572aea1b814c4a59d1b25d4a41c3baa62.tar.gz
master-31e0f0ae-d7d8665572aea1b814c4a59d1b25d4a41c3baa62.tar.bz2
master-31e0f0ae-d7d8665572aea1b814c4a59d1b25d4a41c3baa62.zip
update to 2.6.25.1 and refresh patches
SVN-Revision: 11006
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
index 09248fcdac..c2062f7b0d 100644
--- a/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/Makefile
+Index: linux-2.6.25.1/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/Makefile 2007-09-21 16:23:55.000000000 +0800
-+++ linux-2.6.23-rc6/Makefile 2007-09-21 16:23:56.000000000 +0800
-@@ -508,6 +508,9 @@
+--- linux-2.6.25.1.orig/Makefile
++++ linux-2.6.25.1/Makefile
+@@ -533,6 +533,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
@@ -10,5 +10,5 @@ Index: linux-2.6.23-rc6/Makefile
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
- CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)