summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-02 10:17:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-02 10:17:03 +0000
commitd7d8665572aea1b814c4a59d1b25d4a41c3baa62 (patch)
treee5ff9d6b5df84b7ab7808e1cfd9e0261db5bc4ce /target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
parentaaac1064de71c495d284b981d83f70d3bd445826 (diff)
downloadmaster-31e0f0ae-d7d8665572aea1b814c4a59d1b25d4a41c3baa62.tar.gz
master-31e0f0ae-d7d8665572aea1b814c4a59d1b25d4a41c3baa62.tar.bz2
master-31e0f0ae-d7d8665572aea1b814c4a59d1b25d4a41c3baa62.zip
update to 2.6.25.1 and refresh patches
SVN-Revision: 11006
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
index 302294c082..f2c31e75eb 100644
--- a/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.23/include/linux/LzmaDecode.h
+Index: linux-2.6.25.1/include/linux/LzmaDecode.h
===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/LzmaDecode.h 2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ linux-2.6.25.1/include/linux/LzmaDecode.h
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +103,10 @@ Index: linux-2.6.23/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.23/lib/LzmaDecode.c
+Index: linux-2.6.25.1/lib/LzmaDecode.c
===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/lib/LzmaDecode.c 2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ linux-2.6.25.1/lib/LzmaDecode.c
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,12 +771,12 @@ Index: linux-2.6.23/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.23/lib/Makefile
+Index: linux-2.6.25.1/lib/Makefile
===================================================================
---- linux-2.6.23.orig/lib/Makefile 2007-10-10 13:50:24.000000000 +0800
-+++ linux-2.6.23/lib/Makefile 2007-10-10 13:51:53.000000000 +0800
-@@ -13,7 +13,7 @@
- lib-y += kobject.o kref.o kobject_uevent.o klist.o
+--- linux-2.6.25.1.orig/lib/Makefile
++++ linux-2.6.25.1/lib/Makefile
+@@ -14,7 +14,7 @@ lib-$(CONFIG_SMP) += cpumask.o
+ lib-y += kobject.o kref.o klist.o
obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \
- bust_spinlocks.o hexdump.o kasprintf.o bitmap.o scatterlist.o