summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
commit74215746b332d79139e92650a4240c97e3a88845 (patch)
treec4c9b4bf8791e93a1d21aad5b904bb17a814c726 /target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch
parent2259476f060ea4b9ca9cffa82ad052a690606fab (diff)
downloadmaster-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.tar.gz
master-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.tar.bz2
master-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.zip
refresh generic 2.6.24 patches to match upstream style
SVN-Revision: 11302
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch28
1 files changed, 10 insertions, 18 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch b/target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch
index ebf78107ef..f9d16f3916 100644
--- a/target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch
+++ b/target/linux/generic-2.6/patches-2.6.24/200-sched_esfq.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/include/linux/pkt_sched.h
-===================================================================
---- linux-2.6.24.7.orig/include/linux/pkt_sched.h
-+++ linux-2.6.24.7/include/linux/pkt_sched.h
-@@ -155,8 +155,37 @@ struct tc_sfq_qopt
+--- a/include/linux/pkt_sched.h
++++ b/include/linux/pkt_sched.h
+@@ -155,8 +155,37 @@
*
* The only reason for this is efficiency, it is possible
* to change these parameters in compile time.
@@ -40,11 +38,9 @@ Index: linux-2.6.24.7/include/linux/pkt_sched.h
/* RED section */
enum
-Index: linux-2.6.24.7/net/sched/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/sched/Kconfig
-+++ linux-2.6.24.7/net/sched/Kconfig
-@@ -139,6 +139,37 @@ config NET_SCH_SFQ
+--- a/net/sched/Kconfig
++++ b/net/sched/Kconfig
+@@ -139,6 +139,37 @@
To compile this code as a module, choose M here: the
module will be called sch_sfq.
@@ -82,11 +78,9 @@ Index: linux-2.6.24.7/net/sched/Kconfig
config NET_SCH_TEQL
tristate "True Link Equalizer (TEQL)"
---help---
-Index: linux-2.6.24.7/net/sched/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/sched/Makefile
-+++ linux-2.6.24.7/net/sched/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_NET_SCH_GRED) += sch_gred.o
+--- a/net/sched/Makefile
++++ b/net/sched/Makefile
+@@ -23,6 +23,7 @@
obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o
obj-$(CONFIG_NET_SCH_DSMARK) += sch_dsmark.o
obj-$(CONFIG_NET_SCH_SFQ) += sch_sfq.o
@@ -94,10 +88,8 @@ Index: linux-2.6.24.7/net/sched/Makefile
obj-$(CONFIG_NET_SCH_TBF) += sch_tbf.o
obj-$(CONFIG_NET_SCH_TEQL) += sch_teql.o
obj-$(CONFIG_NET_SCH_PRIO) += sch_prio.o
-Index: linux-2.6.24.7/net/sched/sch_esfq.c
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/net/sched/sch_esfq.c
++++ b/net/sched/sch_esfq.c
@@ -0,0 +1,702 @@
+/*
+ * net/sched/sch_esfq.c Extended Stochastic Fairness Queueing discipline.