summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:16:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:16:45 +0000
commit09de82989a23c0844422dba103d7534a81cfaeef (patch)
treeb82a2992141db38036a3058645e8dcadfb7385ef /target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch
parent6fbcb132369d914e4a9779f23628490243afe6f6 (diff)
downloadmaster-31e0f0ae-09de82989a23c0844422dba103d7534a81cfaeef.tar.gz
master-31e0f0ae-09de82989a23c0844422dba103d7534a81cfaeef.tar.bz2
master-31e0f0ae-09de82989a23c0844422dba103d7534a81cfaeef.zip
generic-2.6/2.6.24: refresh patches
SVN-Revision: 14450
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch b/target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch
index cee1cdc110..52b272c170 100644
--- a/target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch
+++ b/target/linux/generic-2.6/patches-2.6.24/130-netfilter_ipset.patch
@@ -1,7 +1,7 @@
--- a/include/linux/netfilter_ipv4/Kbuild
+++ b/include/linux/netfilter_ipv4/Kbuild
-@@ -45,3 +45,14 @@
-
+@@ -45,3 +45,14 @@ header-y += ipt_ttl.h
+
unifdef-y += ip_queue.h
unifdef-y += ip_tables.h
+
@@ -7534,7 +7534,7 @@
+module_exit(ipt_SET_fini);
--- a/net/ipv4/netfilter/Kconfig
+++ b/net/ipv4/netfilter/Kconfig
-@@ -408,5 +408,122 @@
+@@ -408,5 +408,122 @@ config IP_NF_ARP_MANGLE
Allows altering the ARP packet payload: source and destination
hardware and network addresses.
@@ -7659,7 +7659,7 @@
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -49,6 +49,7 @@
+@@ -49,6 +49,7 @@ obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_o
obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
@@ -7667,7 +7667,7 @@
obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
-@@ -64,6 +65,18 @@
+@@ -64,6 +65,18 @@ obj-$(CONFIG_IP_NF_TARGET_SAME) += ipt_S
obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TOS.o
obj-$(CONFIG_IP_NF_TARGET_TTL) += ipt_TTL.o
obj-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG.o