summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
commit74215746b332d79139e92650a4240c97e3a88845 (patch)
treec4c9b4bf8791e93a1d21aad5b904bb17a814c726 /target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch
parent2259476f060ea4b9ca9cffa82ad052a690606fab (diff)
downloadmaster-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.tar.gz
master-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.tar.bz2
master-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.zip
refresh generic 2.6.24 patches to match upstream style
SVN-Revision: 11302
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch24
1 files changed, 8 insertions, 16 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch b/target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch
index 9b603da4c5..3000af71df 100644
--- a/target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch
+++ b/target/linux/generic-2.6/patches-2.6.24/110-ipp2p_0.8.1rc1.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_ipp2p.h
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_ipp2p.h
++++ b/include/linux/netfilter_ipv4/ipt_ipp2p.h
@@ -0,0 +1,31 @@
+#ifndef __IPT_IPP2P_H
+#define __IPT_IPP2P_H
@@ -34,10 +32,8 @@ Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_ipp2p.h
+#define IPP2P_MUTE (1 << 14)
+#define IPP2P_WASTE (1 << 15)
+#define IPP2P_XDCC (1 << 16)
-Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_ipp2p.c
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/net/ipv4/netfilter/ipt_ipp2p.c
++++ b/net/ipv4/netfilter/ipt_ipp2p.c
@@ -0,0 +1,856 @@
+#if defined(MODVERSIONS)
+#include <linux/modversions.h>
@@ -895,11 +891,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_ipp2p.c
+module_exit(fini);
+
+
-Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-@@ -63,6 +63,12 @@ config IP_NF_MATCH_IPRANGE
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -63,6 +63,12 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -912,11 +906,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
config IP_NF_MATCH_TOS
tristate "TOS match support"
depends on IP_NF_IPTABLES
-Index: linux-2.6.24.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.24.7/net/ipv4/netfilter/Makefile
-@@ -50,6 +50,8 @@ obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -50,6 +50,8 @@
obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o