summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-01-28 13:36:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-01-28 13:36:09 +0000
commit5303deecf170c291df307f23480590b53f8287e5 (patch)
treec19d3bb7b0ac1d963bf2a2875e3456f5872d9ae5 /target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch
parentf66f06c1894b7becb24cad683f10201e04d60724 (diff)
downloadmaster-31e0f0ae-5303deecf170c291df307f23480590b53f8287e5.tar.gz
master-31e0f0ae-5303deecf170c291df307f23480590b53f8287e5.tar.bz2
master-31e0f0ae-5303deecf170c291df307f23480590b53f8287e5.zip
generic 2.6.24 support
SVN-Revision: 10291
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch
new file mode 100644
index 0000000000..09248fcdac
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch
@@ -0,0 +1,14 @@
+Index: linux-2.6.23-rc6/Makefile
+===================================================================
+--- linux-2.6.23-rc6.orig/Makefile 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23-rc6/Makefile 2007-09-21 16:23:56.000000000 +0800
+@@ -508,6 +508,9 @@
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+