summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
commit74215746b332d79139e92650a4240c97e3a88845 (patch)
treec4c9b4bf8791e93a1d21aad5b904bb17a814c726 /target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch
parent2259476f060ea4b9ca9cffa82ad052a690606fab (diff)
downloadmaster-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.tar.gz
master-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.tar.bz2
master-31e0f0ae-74215746b332d79139e92650a4240c97e3a88845.zip
refresh generic 2.6.24 patches to match upstream style
SVN-Revision: 11302
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch18
1 files changed, 6 insertions, 12 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch
index bb41b2df59..5ebf6999fe 100644
--- a/target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.24/002-lzma_decompress.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/include/linux/LzmaDecode.h
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/include/linux/LzmaDecode.h
++++ b/include/linux/LzmaDecode.h
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +101,8 @@ Index: linux-2.6.24.7/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.24.7/lib/LzmaDecode.c
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/lib/LzmaDecode.c
++++ b/lib/LzmaDecode.c
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,11 +767,9 @@ Index: linux-2.6.24.7/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.24.7/lib/Makefile
-===================================================================
---- linux-2.6.24.7.orig/lib/Makefile
-+++ linux-2.6.24.7/lib/Makefile
-@@ -14,7 +14,7 @@ lib-$(CONFIG_SMP) += cpumask.o
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -14,7 +14,7 @@
lib-y += kobject.o kref.o klist.o
obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \
@@ -784,7 +778,7 @@ Index: linux-2.6.24.7/lib/Makefile
ifeq ($(CONFIG_DEBUG_KOBJECT),y)
CFLAGS_kobject.o += -DDEBUG
-@@ -64,6 +64,7 @@ obj-$(CONFIG_SMP) += percpu_counter.o
+@@ -64,6 +64,7 @@
obj-$(CONFIG_AUDIT_GENERIC) += audit.o
obj-$(CONFIG_SWIOTLB) += swiotlb.o