summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-14 00:52:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-14 00:52:15 +0000
commit985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91 (patch)
tree37dd758fe9d6ad4cdfe468d2076850f516c54fbc /target/linux/generic-2.6/patches-2.6.23
parent2da3f6a25641ed7442141ce07943afaaad3b8c31 (diff)
downloadmaster-31e0f0ae-985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91.tar.gz
master-31e0f0ae-985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91.tar.bz2
master-31e0f0ae-985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91.zip
LED driver for PCEngines ALIX boards
This patch adds a driver for the three LEDs that exists on the PCEngines ALIX 2 and 3 series boards. The driver is also added to the Alix profile. Signed-off-by: Petr Liebman <petrliebman@gmail.com> -- SVN-Revision: 9748
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/401-led_alix.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/401-led_alix.patch b/target/linux/generic-2.6/patches-2.6.23/401-led_alix.patch
new file mode 100644
index 0000000000..cb00274b92
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.23/401-led_alix.patch
@@ -0,0 +1,27 @@
+diff -Nur linux-2.6.23.1.orig/drivers/leds/Kconfig linux-2.6.23.1/drivers/leds/Kconfig
+--- linux-2.6.23.1.orig/drivers/leds/Kconfig 2007-10-12 12:43:44.000000000 -0400
++++ linux-2.6.23.1/drivers/leds/Kconfig 2007-10-31 02:36:22.000000000 -0400
+@@ -81,6 +81,12 @@
+ help
+ This option enables support for the PCEngines WRAP programmable LEDs.
+
++config LEDS_ALIX
++ tristate "LED Support for the ALIX 2/3 boards"
++ depends on LEDS_CLASS
++ help
++ This option enables support for the three LEDs on the PCEngines ALIX 2/3 boards.
++
+ config LEDS_H1940
+ tristate "LED Support for iPAQ H1940 device"
+ depends LEDS_CLASS && ARCH_H1940
+diff -Nur linux-2.6.23.1.orig/drivers/leds/Makefile linux-2.6.23.1/drivers/leds/Makefile
+--- linux-2.6.23.1.orig/drivers/leds/Makefile 2007-10-12 12:43:44.000000000 -0400
++++ linux-2.6.23.1/drivers/leds/Makefile 2007-10-31 02:36:17.000000000 -0400
+@@ -14,6 +14,7 @@
+ obj-$(CONFIG_LEDS_AMS_DELTA) += leds-ams-delta.o
+ obj-$(CONFIG_LEDS_NET48XX) += leds-net48xx.o
+ obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
++obj-$(CONFIG_LEDS_ALIX) += leds-alix.o
+ obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
+ obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
+ obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o