summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-04-15 07:33:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-04-15 07:33:43 +0000
commit67fd9d7fba4f966a49012f02622f308b8cb2e7d7 (patch)
tree3a0e3ab118a7aa77efe908e4c4ed39774b58bfcb /target/linux/generic-2.6/patches-2.6.23
parentd80f43d15f4e1fb9c8c45fdafc7f0c8838573047 (diff)
downloadmaster-31e0f0ae-67fd9d7fba4f966a49012f02622f308b8cb2e7d7.tar.gz
master-31e0f0ae-67fd9d7fba4f966a49012f02622f308b8cb2e7d7.tar.bz2
master-31e0f0ae-67fd9d7fba4f966a49012f02622f308b8cb2e7d7.zip
move spi_gpio driver into the kernel, clean-up SPI modules
SVN-Revision: 10844
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch b/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
new file mode 100644
index 0000000000..aa4e6ee0ac
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
@@ -0,0 +1,28 @@
+Index: linux-2.6.23.16/drivers/spi/Kconfig
+===================================================================
+--- linux-2.6.23.16.orig/drivers/spi/Kconfig
++++ linux-2.6.23.16/drivers/spi/Kconfig
+@@ -100,6 +100,11 @@ config SPI_BUTTERFLY
+ inexpensive battery powered microcontroller evaluation board.
+ This same cable can be used to flash new firmware.
+
++config SPI_GPIO
++ tristate "GPIO API based bitbanging SPI controller"
++ depends on SPI_MASTER && GENERIC_GPIO && EXPERIMENTAL
++ select SPI_BITBANG
++
+ config SPI_IMX
+ tristate "Freescale iMX SPI controller"
+ depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
+Index: linux-2.6.23.16/drivers/spi/Makefile
+===================================================================
+--- linux-2.6.23.16.orig/drivers/spi/Makefile
++++ linux-2.6.23.16/drivers/spi/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
+ obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
+ obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
+ obj-$(CONFIG_SPI_BUTTERFLY) += spi_butterfly.o
++obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+ obj-$(CONFIG_SPI_IMX) += spi_imx.o
+ obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
+ obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o