summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-04 11:35:08 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-04 11:35:08 +0000
commit64fbade9399c6413439be939f0c92ebb2724ee87 (patch)
treea175d1e8ee566b98852ee7f43b310fbd018aaf0f /target/linux/generic-2.6/patches-2.6.23
parent7cf4e9f00a6f07393344d0b56ed02c61f5867c9f (diff)
downloadmaster-31e0f0ae-64fbade9399c6413439be939f0c92ebb2724ee87.tar.gz
master-31e0f0ae-64fbade9399c6413439be939f0c92ebb2724ee87.tar.bz2
master-31e0f0ae-64fbade9399c6413439be939f0c92ebb2724ee87.zip
refresh patches
SVN-Revision: 15581
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/100-netfilter_layer7_2.21.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/100-netfilter_layer7_2.21.patch b/target/linux/generic-2.6/patches-2.6.23/100-netfilter_layer7_2.21.patch
index d8b58bf092..c1af264ea4 100644
--- a/target/linux/generic-2.6/patches-2.6.23/100-netfilter_layer7_2.21.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/100-netfilter_layer7_2.21.patch
@@ -16,7 +16,7 @@
+#endif /* _XT_LAYER7_H */
--- a/include/net/netfilter/nf_conntrack.h
+++ b/include/net/netfilter/nf_conntrack.h
-@@ -127,6 +127,22 @@
+@@ -127,6 +127,22 @@ struct nf_conn
u_int32_t secmark;
#endif
@@ -41,7 +41,7 @@
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -633,6 +633,27 @@
+@@ -633,6 +633,27 @@ config NETFILTER_XT_MATCH_STATE
To compile it as a module, choose M here. If unsure, say N.
@@ -71,7 +71,7 @@
depends on NETFILTER_XTABLES
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -71,6 +71,7 @@
+@@ -71,6 +71,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_QUOTA) +
obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
@@ -81,7 +81,7 @@
obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
--- a/net/netfilter/nf_conntrack_core.c
+++ b/net/netfilter/nf_conntrack_core.c
-@@ -207,6 +207,14 @@
+@@ -207,6 +207,14 @@ destroy_conntrack(struct nf_conntrack *n
* too. */
nf_ct_remove_expectations(ct);
@@ -98,7 +98,7 @@
BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
--- a/net/netfilter/nf_conntrack_standalone.c
+++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -179,6 +179,11 @@
+@@ -179,6 +179,11 @@ static int ct_seq_show(struct seq_file *
return -ENOSPC;
#endif