summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-01-26 03:16:11 +0000
committerJohn Crispin <john@openwrt.org>2008-01-26 03:16:11 +0000
commit0844d5fe4950f671712ca16bfecd9baf4ffdf8a6 (patch)
treeea17d1e38caec2ef3ee57630244a87b480b9eabd /target/linux/generic-2.6/patches-2.6.23
parent929767622f857b2371ca8f9a8b2e989dc0aa7a80 (diff)
downloadmaster-31e0f0ae-0844d5fe4950f671712ca16bfecd9baf4ffdf8a6.tar.gz
master-31e0f0ae-0844d5fe4950f671712ca16bfecd9baf4ffdf8a6.tar.bz2
master-31e0f0ae-0844d5fe4950f671712ca16bfecd9baf4ffdf8a6.zip
add generic gpio char dev for CONFIG_GENERIC_GPIO archs
SVN-Revision: 10261
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/920-gpio_dev.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/920-gpio_dev.patch b/target/linux/generic-2.6/patches-2.6.23/920-gpio_dev.patch
new file mode 100644
index 0000000000..81c206b657
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.23/920-gpio_dev.patch
@@ -0,0 +1,35 @@
+Index: linux-2.6.23.14/arch/arm/Kconfig
+===================================================================
+--- linux-2.6.23.14.orig/arch/arm/Kconfig 2008-01-26 02:46:18.000000000 +0100
++++ linux-2.6.23.14/arch/arm/Kconfig 2008-01-26 02:46:33.000000000 +0100
+@@ -1039,6 +1039,8 @@
+
+ source "drivers/leds/Kconfig"
+
++source "drivers/gpio/Kconfig"
++
+ source "drivers/media/Kconfig"
+
+ source "drivers/video/Kconfig"
+Index: linux-2.6.23.14/drivers/Kconfig
+===================================================================
+--- linux-2.6.23.14.orig/drivers/Kconfig 2008-01-26 02:45:44.000000000 +0100
++++ linux-2.6.23.14/drivers/Kconfig 2008-01-26 02:46:05.000000000 +0100
+@@ -74,6 +74,8 @@
+
+ source "drivers/leds/Kconfig"
+
++source "drivers/gpio/Kconfig"
++
+ source "drivers/infiniband/Kconfig"
+
+ source "drivers/edac/Kconfig"
+Index: linux-2.6.23.14/drivers/Makefile
+===================================================================
+--- linux-2.6.23.14.orig/drivers/Makefile 2008-01-26 02:44:13.000000000 +0100
++++ linux-2.6.23.14/drivers/Makefile 2008-01-26 02:44:42.000000000 +0100
+@@ -88,3 +88,4 @@
+ obj-$(CONFIG_HID) += hid/
+ obj-$(CONFIG_PPC_PS3) += ps3/
+ obj-$(CONFIG_OF) += of/
++obj-$(CONFIG_GPIO_DEVICE) += gpio/