summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:51 +0000
commit37044cf01e5764164d34a4bfe14f9f00f7a2f6ea (patch)
treedb857f99d1b528f6f722bda21b589e60a7461598 /target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
parent7d8b70a1ece7a0f5078688e2ccd4b11e4444d3fe (diff)
downloadmaster-31e0f0ae-37044cf01e5764164d34a4bfe14f9f00f7a2f6ea.tar.gz
master-31e0f0ae-37044cf01e5764164d34a4bfe14f9f00f7a2f6ea.tar.bz2
master-31e0f0ae-37044cf01e5764164d34a4bfe14f9f00f7a2f6ea.zip
refresh generic 2.6.23 patches
SVN-Revision: 11187
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch b/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
index 43d73d0bfa..4a66308ece 100644
--- a/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.24.5/drivers/w1/masters/Kconfig
+Index: linux-2.6.23.17/drivers/w1/masters/Kconfig
===================================================================
---- linux-2.6.23.16.orig/drivers/w1/masters/Kconfig
-+++ linux-2.6.23.16/drivers/w1/masters/Kconfig
+--- linux-2.6.23.17.orig/drivers/w1/masters/Kconfig
++++ linux-2.6.23.17/drivers/w1/masters/Kconfig
@@ -42,5 +42,15 @@ config W1_MASTER_DS1WM
in HP iPAQ devices like h5xxx, h2200, and ASIC3-based like
hx4700.
@@ -18,19 +18,19 @@ Index: linux-2.6.24.5/drivers/w1/masters/Kconfig
+
endmenu
-Index: linux-2.6.23.16/drivers/w1/masters/Makefile
+Index: linux-2.6.23.17/drivers/w1/masters/Makefile
===================================================================
---- linux-2.6.23.16.orig/drivers/w1/masters/Makefile
-+++ linux-2.6.23.16/drivers/w1/masters/Makefile
+--- linux-2.6.23.17.orig/drivers/w1/masters/Makefile
++++ linux-2.6.23.17/drivers/w1/masters/Makefile
@@ -6,3 +6,4 @@ obj-$(CONFIG_W1_MASTER_MATROX) += matro
obj-$(CONFIG_W1_MASTER_DS2490) += ds2490.o
obj-$(CONFIG_W1_MASTER_DS2482) += ds2482.o
obj-$(CONFIG_W1_MASTER_DS1WM) += ds1wm.o
+obj-$(CONFIG_W1_MASTER_GPIO) += w1-gpio.o
-Index: linux-2.6.23.16/drivers/w1/masters/w1-gpio.c
+Index: linux-2.6.23.17/drivers/w1/masters/w1-gpio.c
===================================================================
--- /dev/null
-+++ linux-2.6.23.16/drivers/w1/masters/w1-gpio.c
++++ linux-2.6.23.17/drivers/w1/masters/w1-gpio.c
@@ -0,0 +1,124 @@
+/*
+ * w1-gpio - GPIO w1 bus master driver
@@ -156,10 +156,10 @@ Index: linux-2.6.23.16/drivers/w1/masters/w1-gpio.c
+MODULE_DESCRIPTION("GPIO w1 bus master driver");
+MODULE_AUTHOR("Ville Syrjala <syrjala@sci.fi>");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.23.16/include/linux/w1-gpio.h
+Index: linux-2.6.23.17/include/linux/w1-gpio.h
===================================================================
--- /dev/null
-+++ linux-2.6.23.16/include/linux/w1-gpio.h
++++ linux-2.6.23.17/include/linux/w1-gpio.h
@@ -0,0 +1,23 @@
+/*
+ * w1-gpio interface to platform code