summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-01 18:16:10 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-01 18:16:10 +0000
commitf81257ca34af15ae5ba6129870b4fad356709ce6 (patch)
treee5eb493d4cd48cfbce9e71a89f4b10cefc998439 /target/linux/generic-2.6/patches-2.6.23/410-gpio_buttons.patch
parent7f9fd5033cbebc20e18b3b30ff6e821d3cc1c9d7 (diff)
downloadmaster-31e0f0ae-f81257ca34af15ae5ba6129870b4fad356709ce6.tar.gz
master-31e0f0ae-f81257ca34af15ae5ba6129870b4fad356709ce6.tar.bz2
master-31e0f0ae-f81257ca34af15ae5ba6129870b4fad356709ce6.zip
remove 2.6.23 support, as the last target using that has been nuked, too
SVN-Revision: 16275
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/410-gpio_buttons.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.23/410-gpio_buttons.patch
deleted file mode 100644
index 31d40c9449..0000000000
--- a/target/linux/generic-2.6/patches-2.6.23/410-gpio_buttons.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -183,4 +183,20 @@ config HP_SDC_RTC
- Say Y here if you want to support the built-in real time clock
- of the HP SDC controller.
-
-+config INPUT_GPIO_BUTTONS
-+ tristate "Polled GPIO buttons interface"
-+ depends on GENERIC_GPIO
-+ select INPUT_POLLDEV
-+ help
-+ This driver implements support for buttons connected
-+ to GPIO pins of various CPUs (and some other chips).
-+
-+ Say Y here if your device has buttons connected
-+ directly to such GPIO pins. Your board-specific
-+ setup logic must also provide a platform device,
-+ with configuration data saying which GPIOs are used.
-+
-+ To compile this driver as a module, choose M here: the
-+ module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -18,3 +18,4 @@ obj-$(CONFIG_INPUT_POWERMATE) += powerm
- obj-$(CONFIG_INPUT_YEALINK) += yealink.o
- obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.o
- obj-$(CONFIG_INPUT_UINPUT) += uinput.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o