summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-04-15 06:11:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-04-15 06:11:23 +0000
commitd80f43d15f4e1fb9c8c45fdafc7f0c8838573047 (patch)
treea2f4cbd0b328b674326665e96c88fd493ef8dc00 /target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
parentece27874c17a3f84bae9af15399c0d92beb2620e (diff)
downloadmaster-31e0f0ae-d80f43d15f4e1fb9c8c45fdafc7f0c8838573047.tar.gz
master-31e0f0ae-d80f43d15f4e1fb9c8c45fdafc7f0c8838573047.tar.bz2
master-31e0f0ae-d80f43d15f4e1fb9c8c45fdafc7f0c8838573047.zip
update iptables to 1.4.0 (2.6 kernels only), refresh kernel patches
SVN-Revision: 10843
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
index 058dda5c28..073951a15c 100644
--- a/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.23/net/netfilter/Kconfig
+Index: linux-2.6.23.16/net/netfilter/Kconfig
===================================================================
---- linux-2.6.23.orig/net/netfilter/Kconfig
-+++ linux-2.6.23/net/netfilter/Kconfig
+--- linux-2.6.23.16.orig/net/netfilter/Kconfig
++++ linux-2.6.23.16/net/netfilter/Kconfig
@@ -401,6 +401,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
To compile it as a module, choose M here. If unsure, say N.
@@ -26,22 +26,22 @@ Index: linux-2.6.23/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.23/net/netfilter/Makefile
+Index: linux-2.6.23.16/net/netfilter/Makefile
===================================================================
---- linux-2.6.23.orig/net/netfilter/Makefile
-+++ linux-2.6.23/net/netfilter/Makefile
-@@ -49,6 +49,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG)
+--- linux-2.6.23.16.orig/net/netfilter/Makefile
++++ linux-2.6.23.16/net/netfilter/Makefile
+@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG)
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
+obj-$(CONFIG_NETFILTER_XT_TARGET_TARPIT) += xt_TARPIT.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
-
-Index: linux-2.6.23/net/netfilter/xt_TARPIT.c
+ obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
+Index: linux-2.6.23.16/net/netfilter/xt_TARPIT.c
===================================================================
--- /dev/null
-+++ linux-2.6.23/net/netfilter/xt_TARPIT.c
++++ linux-2.6.23.16/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,280 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using