summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-12-08 15:52:26 +0000
committerTim Yardley <lst@openwrt.org>2007-12-08 15:52:26 +0000
commit59a715fdd50d03f5d3d2802475e784bc903eaa93 (patch)
treea832befa89f935fcb38a035a1cea84b59c82386f /target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch
parent06b6aaae20631ee3054f26a8571a0cfc83841ce1 (diff)
downloadmaster-31e0f0ae-59a715fdd50d03f5d3d2802475e784bc903eaa93.tar.gz
master-31e0f0ae-59a715fdd50d03f5d3d2802475e784bc903eaa93.tar.bz2
master-31e0f0ae-59a715fdd50d03f5d3d2802475e784bc903eaa93.zip
updated layer7 to 2.15.. current is 2.16.1, i might bump again, this has been uncommitted for a bit
SVN-Revision: 9674
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch36
1 files changed, 18 insertions, 18 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch b/target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch
index dfccbe0483..b86d494813 100644
--- a/target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/110-ipp2p_0.8.1rc1.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_ipp2p.h
+Index: linux-2.6.23.1/include/linux/netfilter_ipv4/ipt_ipp2p.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_ipp2p.h 2007-09-21 16:24:00.000000000 +0800
++++ linux-2.6.23.1/include/linux/netfilter_ipv4/ipt_ipp2p.h 2007-11-19 18:22:19.000000000 -0600
@@ -0,0 +1,31 @@
+#ifndef __IPT_IPP2P_H
+#define __IPT_IPP2P_H
@@ -34,10 +34,10 @@ Index: linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_ipp2p.h
+#define IPP2P_MUTE (1 << 14)
+#define IPP2P_WASTE (1 << 15)
+#define IPP2P_XDCC (1 << 16)
-Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_ipp2p.c
+Index: linux-2.6.23.1/net/ipv4/netfilter/ipt_ipp2p.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/net/ipv4/netfilter/ipt_ipp2p.c 2007-09-21 16:24:00.000000000 +0800
++++ linux-2.6.23.1/net/ipv4/netfilter/ipt_ipp2p.c 2007-11-19 18:22:19.000000000 -0600
@@ -0,0 +1,856 @@
+#if defined(MODVERSIONS)
+#include <linux/modversions.h>
@@ -895,13 +895,13 @@ Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_ipp2p.c
+module_exit(fini);
+
+
-Index: linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig
+Index: linux-2.6.23.1/net/ipv4/netfilter/Kconfig
===================================================================
---- linux-2.6.23-rc6.orig/net/ipv4/netfilter/Kconfig 2007-09-21 16:23:59.000000000 +0800
-+++ linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig 2007-09-21 16:24:00.000000000 +0800
-@@ -81,6 +81,12 @@
- help
- Say Y to get lots of debugging output.
+--- linux-2.6.23.1.orig/net/ipv4/netfilter/Kconfig 2007-11-19 18:21:55.000000000 -0600
++++ linux-2.6.23.1/net/ipv4/netfilter/Kconfig 2007-11-19 18:22:19.000000000 -0600
+@@ -63,6 +63,12 @@
+
+ To compile it as a module, choose M here. If unsure, say N.
+config IP_NF_MATCH_IPP2P
+ tristate "IPP2P"
@@ -912,16 +912,16 @@ Index: linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig
config IP_NF_MATCH_TOS
tristate "TOS match support"
depends on IP_NF_IPTABLES
-Index: linux-2.6.23-rc6/net/ipv4/netfilter/Makefile
+Index: linux-2.6.23.1/net/ipv4/netfilter/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/net/ipv4/netfilter/Makefile 2007-09-21 16:23:59.000000000 +0800
-+++ linux-2.6.23-rc6/net/ipv4/netfilter/Makefile 2007-09-21 16:24:00.000000000 +0800
-@@ -49,7 +49,7 @@
- obj-$(CONFIG_IP_NF_MATCH_AH) += ipt_ah.o
+--- linux-2.6.23.1.orig/net/ipv4/netfilter/Makefile 2007-11-19 18:21:55.000000000 -0600
++++ linux-2.6.23.1/net/ipv4/netfilter/Makefile 2007-11-19 18:23:45.000000000 -0600
+@@ -50,6 +50,8 @@
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
obj-$(CONFIG_IP_NF_MATCH_ADDRTYPE) += ipt_addrtype.o
--
-+obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
- obj-$(CONFIG_IP_NF_MATCH_LAYER7) += ipt_layer7.o
++obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
++
# targets
+ obj-$(CONFIG_IP_NF_TARGET_REJECT) += ipt_REJECT.o
+ obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TOS.o