summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorEugene Konev <ejka@imfi.kspu.ru>2007-10-10 06:20:25 +0000
committerEugene Konev <ejka@imfi.kspu.ru>2007-10-10 06:20:25 +0000
commit72f5fa6b928901b03d3e07c5e3c82f024244019f (patch)
tree1a23194815fe641571a17a2b0fa02b15e3895acb /target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
parente7fb9324047193d4045567521e5a14e88da2a06f (diff)
downloadmaster-31e0f0ae-72f5fa6b928901b03d3e07c5e3c82f024244019f.tar.gz
master-31e0f0ae-72f5fa6b928901b03d3e07c5e3c82f024244019f.tar.bz2
master-31e0f0ae-72f5fa6b928901b03d3e07c5e3c82f024244019f.zip
sync for 2.6.23-final
SVN-Revision: 9234
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
index f31f18cd8c..3d98ffeacb 100644
--- a/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.23-rc6/include/linux/LzmaDecode.h
+Index: linux-2.6.23/include/linux/LzmaDecode.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/include/linux/LzmaDecode.h 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23/include/linux/LzmaDecode.h 2007-10-10 13:51:27.000000000 +0800
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +103,10 @@ Index: linux-2.6.23-rc6/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.23-rc6/lib/LzmaDecode.c
+Index: linux-2.6.23/lib/LzmaDecode.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/lib/LzmaDecode.c 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23/lib/LzmaDecode.c 2007-10-10 13:51:27.000000000 +0800
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,16 +771,16 @@ Index: linux-2.6.23-rc6/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.23-rc6/lib/Makefile
+Index: linux-2.6.23/lib/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/lib/Makefile 2007-09-21 16:23:55.000000000 +0800
-+++ linux-2.6.23-rc6/lib/Makefile 2007-09-21 16:23:55.000000000 +0800
+--- linux-2.6.23.orig/lib/Makefile 2007-10-10 13:50:24.000000000 +0800
++++ linux-2.6.23/lib/Makefile 2007-10-10 13:51:53.000000000 +0800
@@ -13,7 +13,7 @@
lib-y += kobject.o kref.o kobject_uevent.o klist.o
obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \
-- bust_spinlocks.o hexdump.o
-+ bust_spinlocks.o hexdump.o LzmaDecode.o
+- bust_spinlocks.o hexdump.o kasprintf.o
++ bust_spinlocks.o hexdump.o kasprintf.o LzmaDecode.o
ifeq ($(CONFIG_DEBUG_KOBJECT),y)
CFLAGS_kobject.o += -DDEBUG