summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:51 +0000
commit37044cf01e5764164d34a4bfe14f9f00f7a2f6ea (patch)
treedb857f99d1b528f6f722bda21b589e60a7461598 /target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
parent7d8b70a1ece7a0f5078688e2ccd4b11e4444d3fe (diff)
downloadmaster-31e0f0ae-37044cf01e5764164d34a4bfe14f9f00f7a2f6ea.tar.gz
master-31e0f0ae-37044cf01e5764164d34a4bfe14f9f00f7a2f6ea.tar.bz2
master-31e0f0ae-37044cf01e5764164d34a4bfe14f9f00f7a2f6ea.zip
refresh generic 2.6.23 patches
SVN-Revision: 11187
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
index 3d98ffeacb..a191ae205c 100644
--- a/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.23/include/linux/LzmaDecode.h
+Index: linux-2.6.23.17/include/linux/LzmaDecode.h
===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/LzmaDecode.h 2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ linux-2.6.23.17/include/linux/LzmaDecode.h
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +103,10 @@ Index: linux-2.6.23/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.23/lib/LzmaDecode.c
+Index: linux-2.6.23.17/lib/LzmaDecode.c
===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/lib/LzmaDecode.c 2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ linux-2.6.23.17/lib/LzmaDecode.c
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,11 +771,11 @@ Index: linux-2.6.23/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.23/lib/Makefile
+Index: linux-2.6.23.17/lib/Makefile
===================================================================
---- linux-2.6.23.orig/lib/Makefile 2007-10-10 13:50:24.000000000 +0800
-+++ linux-2.6.23/lib/Makefile 2007-10-10 13:51:53.000000000 +0800
-@@ -13,7 +13,7 @@
+--- linux-2.6.23.17.orig/lib/Makefile
++++ linux-2.6.23.17/lib/Makefile
+@@ -13,7 +13,7 @@ lib-$(CONFIG_SMP) += cpumask.o
lib-y += kobject.o kref.o kobject_uevent.o klist.o
obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \
@@ -784,7 +784,7 @@ Index: linux-2.6.23/lib/Makefile
ifeq ($(CONFIG_DEBUG_KOBJECT),y)
CFLAGS_kobject.o += -DDEBUG
-@@ -62,6 +62,7 @@
+@@ -62,6 +62,7 @@ obj-$(CONFIG_SMP) += percpu_counter.o
obj-$(CONFIG_AUDIT_GENERIC) += audit.o
obj-$(CONFIG_SWIOTLB) += swiotlb.o