summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-05 17:01:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-05 17:01:00 +0000
commit2ff1596a2249657e543c0cdd7ba3b05eb33e645c (patch)
treebfeb7a11889eb81e2e7f16bcd91b913b1a124ba6 /target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
parent04fd31f429a5450df483fa5178678b6de2b91e8c (diff)
downloadmaster-31e0f0ae-2ff1596a2249657e543c0cdd7ba3b05eb33e645c.tar.gz
master-31e0f0ae-2ff1596a2249657e543c0cdd7ba3b05eb33e645c.tar.bz2
master-31e0f0ae-2ff1596a2249657e543c0cdd7ba3b05eb33e645c.zip
refresh generic 2.6.23 patches in upstream style
SVN-Revision: 11366
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch18
1 files changed, 6 insertions, 12 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
index a191ae205c..d6c7e311ee 100644
--- a/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/002-lzma_decompress.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.17/include/linux/LzmaDecode.h
-===================================================================
--- /dev/null
-+++ linux-2.6.23.17/include/linux/LzmaDecode.h
++++ b/include/linux/LzmaDecode.h
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +101,8 @@ Index: linux-2.6.23.17/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.23.17/lib/LzmaDecode.c
-===================================================================
--- /dev/null
-+++ linux-2.6.23.17/lib/LzmaDecode.c
++++ b/lib/LzmaDecode.c
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,11 +767,9 @@ Index: linux-2.6.23.17/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.23.17/lib/Makefile
-===================================================================
---- linux-2.6.23.17.orig/lib/Makefile
-+++ linux-2.6.23.17/lib/Makefile
-@@ -13,7 +13,7 @@ lib-$(CONFIG_SMP) += cpumask.o
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -13,7 +13,7 @@
lib-y += kobject.o kref.o kobject_uevent.o klist.o
obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \
@@ -784,7 +778,7 @@ Index: linux-2.6.23.17/lib/Makefile
ifeq ($(CONFIG_DEBUG_KOBJECT),y)
CFLAGS_kobject.o += -DDEBUG
-@@ -62,6 +62,7 @@ obj-$(CONFIG_SMP) += percpu_counter.o
+@@ -62,6 +62,7 @@
obj-$(CONFIG_AUDIT_GENERIC) += audit.o
obj-$(CONFIG_SWIOTLB) += swiotlb.o