summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-16 12:40:48 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-16 12:40:48 +0000
commit2f4fa6de7453790e0626da50078b2756dd747ca6 (patch)
treedb6af3bddf359b63b08b4ad6cd37535551613bec /target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch
parente147bf8fa3c6e9023fbda64bfeb95de2910ab656 (diff)
downloadmaster-31e0f0ae-2f4fa6de7453790e0626da50078b2756dd747ca6.tar.gz
master-31e0f0ae-2f4fa6de7453790e0626da50078b2756dd747ca6.tar.bz2
master-31e0f0ae-2f4fa6de7453790e0626da50078b2756dd747ca6.zip
refresh generic 2.6.22 patches
SVN-Revision: 11498
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch110
1 files changed, 30 insertions, 80 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch b/target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch
index f59f450453..4d30282511 100644
--- a/target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/130-netfilter_ipset.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set.h
++++ b/include/linux/netfilter_ipv4/ip_set.h
@@ -0,0 +1,498 @@
+#ifndef _IP_SET_H
+#define _IP_SET_H
@@ -501,10 +499,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set.h
+#endif /* __KERNEL__ */
+
+#endif /*_IP_SET_H*/
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iphash.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iphash.h
++++ b/include/linux/netfilter_ipv4/ip_set_iphash.h
@@ -0,0 +1,30 @@
+#ifndef __IP_SET_IPHASH_H
+#define __IP_SET_IPHASH_H
@@ -536,10 +532,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iphash.h
+};
+
+#endif /* __IP_SET_IPHASH_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_ipmap.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_ipmap.h
++++ b/include/linux/netfilter_ipv4/ip_set_ipmap.h
@@ -0,0 +1,56 @@
+#ifndef __IP_SET_IPMAP_H
+#define __IP_SET_IPMAP_H
@@ -597,10 +591,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_ipmap.h
+}
+
+#endif /* __IP_SET_IPMAP_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_ipporthash.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_ipporthash.h
++++ b/include/linux/netfilter_ipv4/ip_set_ipporthash.h
@@ -0,0 +1,34 @@
+#ifndef __IP_SET_IPPORTHASH_H
+#define __IP_SET_IPPORTHASH_H
@@ -636,10 +628,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_ipporthash.h
+};
+
+#endif /* __IP_SET_IPPORTHASH_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iptree.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iptree.h
++++ b/include/linux/netfilter_ipv4/ip_set_iptree.h
@@ -0,0 +1,40 @@
+#ifndef __IP_SET_IPTREE_H
+#define __IP_SET_IPTREE_H
@@ -681,10 +671,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iptree.h
+};
+
+#endif /* __IP_SET_IPTREE_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iptreemap.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iptreemap.h
++++ b/include/linux/netfilter_ipv4/ip_set_iptreemap.h
@@ -0,0 +1,40 @@
+#ifndef __IP_SET_IPTREEMAP_H
+#define __IP_SET_IPTREEMAP_H
@@ -726,10 +714,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_iptreemap.h
+};
+
+#endif /* __IP_SET_IPTREEMAP_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_jhash.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_jhash.h
++++ b/include/linux/netfilter_ipv4/ip_set_jhash.h
@@ -0,0 +1,148 @@
+#ifndef _LINUX_IPSET_JHASH_H
+#define _LINUX_IPSET_JHASH_H
@@ -879,10 +865,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_jhash.h
+}
+
+#endif /* _LINUX_IPSET_JHASH_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_macipmap.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_macipmap.h
++++ b/include/linux/netfilter_ipv4/ip_set_macipmap.h
@@ -0,0 +1,38 @@
+#ifndef __IP_SET_MACIPMAP_H
+#define __IP_SET_MACIPMAP_H
@@ -922,10 +906,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_macipmap.h
+};
+
+#endif /* __IP_SET_MACIPMAP_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_malloc.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_malloc.h
++++ b/include/linux/netfilter_ipv4/ip_set_malloc.h
@@ -0,0 +1,116 @@
+#ifndef _IP_SET_MALLOC_H
+#define _IP_SET_MALLOC_H
@@ -1043,10 +1025,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_malloc.h
+#endif /* __KERNEL__ */
+
+#endif /*_IP_SET_MALLOC_H*/
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_nethash.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_nethash.h
++++ b/include/linux/netfilter_ipv4/ip_set_nethash.h
@@ -0,0 +1,55 @@
+#ifndef __IP_SET_NETHASH_H
+#define __IP_SET_NETHASH_H
@@ -1103,10 +1083,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_nethash.h
+}
+
+#endif /* __IP_SET_NETHASH_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_portmap.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_portmap.h
++++ b/include/linux/netfilter_ipv4/ip_set_portmap.h
@@ -0,0 +1,25 @@
+#ifndef __IP_SET_PORTMAP_H
+#define __IP_SET_PORTMAP_H
@@ -1133,10 +1111,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ip_set_portmap.h
+};
+
+#endif /* __IP_SET_PORTMAP_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_set.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_set.h
++++ b/include/linux/netfilter_ipv4/ipt_set.h
@@ -0,0 +1,21 @@
+#ifndef _IPT_SET_H
+#define _IPT_SET_H
@@ -1159,10 +1135,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_set.h
+};
+
+#endif /*_IPT_SET_H*/
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set.c
++++ b/net/ipv4/netfilter/ip_set.c
@@ -0,0 +1,2003 @@
+/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
+ * Patrick Schaaf <bof@bof.de>
@@ -3167,10 +3141,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set.c
+
+module_init(ip_set_init);
+module_exit(ip_set_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_iphash.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_iphash.c
++++ b/net/ipv4/netfilter/ip_set_iphash.c
@@ -0,0 +1,429 @@
+/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
+ *
@@ -3601,10 +3573,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_iphash.c
+
+module_init(ip_set_iphash_init);
+module_exit(ip_set_iphash_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_ipmap.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_ipmap.c
++++ b/net/ipv4/netfilter/ip_set_ipmap.c
@@ -0,0 +1,336 @@
+/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
+ * Patrick Schaaf <bof@bof.de>
@@ -3942,10 +3912,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_ipmap.c
+
+module_init(ip_set_ipmap_init);
+module_exit(ip_set_ipmap_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_ipporthash.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_ipporthash.c
++++ b/net/ipv4/netfilter/ip_set_ipporthash.c
@@ -0,0 +1,581 @@
+/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
+ *
@@ -4528,10 +4496,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_ipporthash.c
+
+module_init(ip_set_ipporthash_init);
+module_exit(ip_set_ipporthash_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_iptree.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_iptree.c
++++ b/net/ipv4/netfilter/ip_set_iptree.c
@@ -0,0 +1,612 @@
+/* Copyright (C) 2005 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
+ *
@@ -5145,10 +5111,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_iptree.c
+
+module_init(ip_set_iptree_init);
+module_exit(ip_set_iptree_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_iptreemap.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_iptreemap.c
++++ b/net/ipv4/netfilter/ip_set_iptreemap.c
@@ -0,0 +1,829 @@
+/* Copyright (C) 2007 Sven Wegener <sven.wegener@stealer.net>
+ *
@@ -5979,10 +5943,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_iptreemap.c
+
+module_init(ip_set_iptreemap_init);
+module_exit(ip_set_iptreemap_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_macipmap.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_macipmap.c
++++ b/net/ipv4/netfilter/ip_set_macipmap.c
@@ -0,0 +1,375 @@
+/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
+ * Patrick Schaaf <bof@bof.de>
@@ -6359,10 +6321,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_macipmap.c
+
+module_init(ip_set_macipmap_init);
+module_exit(ip_set_macipmap_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_nethash.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_nethash.c
++++ b/net/ipv4/netfilter/ip_set_nethash.c
@@ -0,0 +1,497 @@
+/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
+ *
@@ -6861,10 +6821,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_nethash.c
+
+module_init(ip_set_nethash_init);
+module_exit(ip_set_nethash_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_portmap.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ip_set_portmap.c
++++ b/net/ipv4/netfilter/ip_set_portmap.c
@@ -0,0 +1,346 @@
+/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
+ *
@@ -7212,10 +7170,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ip_set_portmap.c
+
+module_init(ip_set_portmap_init);
+module_exit(ip_set_portmap_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_set.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ipt_set.c
++++ b/net/ipv4/netfilter/ipt_set.c
@@ -0,0 +1,160 @@
+/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
+ * Patrick Schaaf <bof@bof.de>
@@ -7377,10 +7333,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_set.c
+
+module_init(ipt_ipset_init);
+module_exit(ipt_ipset_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_SET.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ipt_SET.c
++++ b/net/ipv4/netfilter/ipt_SET.c
@@ -0,0 +1,172 @@
+/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
+ * Patrick Schaaf <bof@bof.de>
@@ -7554,11 +7508,9 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_SET.c
+
+module_init(ipt_SET_init);
+module_exit(ipt_SET_fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.22.19/net/ipv4/netfilter/Kconfig
-@@ -408,5 +408,122 @@ config IP_NF_ARP_MANGLE
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -408,5 +408,122 @@
Allows altering the ARP packet payload: source and destination
hardware and network addresses.
@@ -7681,11 +7633,9 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/Kconfig
+
endmenu
-Index: linux-2.6.22.19/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.22.19.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.22.19/net/ipv4/netfilter/Makefile
-@@ -48,6 +48,7 @@ obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -48,6 +48,7 @@
obj-$(CONFIG_IP_NF_MATCH_ECN) += ipt_ecn.o
obj-$(CONFIG_IP_NF_MATCH_AH) += ipt_ah.o
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
@@ -7693,7 +7643,7 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/Makefile
obj-$(CONFIG_IP_NF_MATCH_ADDRTYPE) += ipt_addrtype.o
obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
-@@ -63,6 +64,18 @@ obj-$(CONFIG_IP_NF_TARGET_LOG) += ipt_LO
+@@ -63,6 +64,18 @@
obj-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG.o
obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o
obj-$(CONFIG_IP_NF_TARGET_TTL) += ipt_TTL.o