summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:13 +0000
commit7d8b70a1ece7a0f5078688e2ccd4b11e4444d3fe (patch)
tree2c3e3d4268c3d9f5742e872e32686ebfebd970d4 /target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch
parent6761ddd557729c97c12d19832c70e279839b4d5d (diff)
downloadmaster-31e0f0ae-7d8b70a1ece7a0f5078688e2ccd4b11e4444d3fe.tar.gz
master-31e0f0ae-7d8b70a1ece7a0f5078688e2ccd4b11e4444d3fe.tar.bz2
master-31e0f0ae-7d8b70a1ece7a0f5078688e2ccd4b11e4444d3fe.zip
refresh generic 2.6.22 patches
SVN-Revision: 11186
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch89
1 files changed, 50 insertions, 39 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch b/target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch
index efe21bf721..e9c1d69f10 100644
--- a/target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/001-squashfs.patch
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.22.4/fs/Kconfig linux-2.6.22.4-squashfs/fs/Kconfig
---- linux-2.6.22.4/fs/Kconfig 2007-08-21 06:33:06.000000000 +0200
-+++ linux-2.6.22.4-squashfs/fs/Kconfig 2007-09-20 19:13:44.000000000 +0200
-@@ -1367,6 +1367,71 @@
+Index: linux-2.6.22.19/fs/Kconfig
+===================================================================
+--- linux-2.6.22.19.orig/fs/Kconfig
++++ linux-2.6.22.19/fs/Kconfig
+@@ -1367,6 +1367,71 @@ config CRAMFS
If unsure, say N.
@@ -73,10 +74,11 @@ diff -urN linux-2.6.22.4/fs/Kconfig linux-2.6.22.4-squashfs/fs/Kconfig
config VXFS_FS
tristate "FreeVxFS file system support (VERITAS VxFS(TM) compatible)"
depends on BLOCK
-diff -urN linux-2.6.22.4/fs/Makefile linux-2.6.22.4-squashfs/fs/Makefile
---- linux-2.6.22.4/fs/Makefile 2007-08-21 06:33:06.000000000 +0200
-+++ linux-2.6.22.4-squashfs/fs/Makefile 2007-09-20 19:13:44.000000000 +0200
-@@ -72,6 +72,7 @@
+Index: linux-2.6.22.19/fs/Makefile
+===================================================================
+--- linux-2.6.22.19.orig/fs/Makefile
++++ linux-2.6.22.19/fs/Makefile
+@@ -72,6 +72,7 @@ obj-$(CONFIG_JBD) += jbd/
obj-$(CONFIG_JBD2) += jbd2/
obj-$(CONFIG_EXT2_FS) += ext2/
obj-$(CONFIG_CRAMFS) += cramfs/
@@ -84,9 +86,10 @@ diff -urN linux-2.6.22.4/fs/Makefile linux-2.6.22.4-squashfs/fs/Makefile
obj-$(CONFIG_RAMFS) += ramfs/
obj-$(CONFIG_HUGETLBFS) += hugetlbfs/
obj-$(CONFIG_CODA_FS) += coda/
-diff -urN linux-2.6.22.4/fs/squashfs/inode.c linux-2.6.22.4-squashfs/fs/squashfs/inode.c
---- linux-2.6.22.4/fs/squashfs/inode.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.22.4-squashfs/fs/squashfs/inode.c 2007-09-20 19:13:44.000000000 +0200
+Index: linux-2.6.22.19/fs/squashfs/inode.c
+===================================================================
+--- /dev/null
++++ linux-2.6.22.19/fs/squashfs/inode.c
@@ -0,0 +1,2122 @@
+/*
+ * Squashfs - a compressed read only filesystem for Linux
@@ -2210,9 +2213,10 @@ diff -urN linux-2.6.22.4/fs/squashfs/inode.c linux-2.6.22.4-squashfs/fs/squashfs
+MODULE_DESCRIPTION("squashfs, a compressed read-only filesystem");
+MODULE_AUTHOR("Phillip Lougher <phillip@lougher.org.uk>");
+MODULE_LICENSE("GPL");
-diff -urN linux-2.6.22.4/fs/squashfs/Makefile linux-2.6.22.4-squashfs/fs/squashfs/Makefile
---- linux-2.6.22.4/fs/squashfs/Makefile 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.22.4-squashfs/fs/squashfs/Makefile 2007-09-20 19:13:44.000000000 +0200
+Index: linux-2.6.22.19/fs/squashfs/Makefile
+===================================================================
+--- /dev/null
++++ linux-2.6.22.19/fs/squashfs/Makefile
@@ -0,0 +1,7 @@
+#
+# Makefile for the linux squashfs routines.
@@ -2221,9 +2225,10 @@ diff -urN linux-2.6.22.4/fs/squashfs/Makefile linux-2.6.22.4-squashfs/fs/squashf
+obj-$(CONFIG_SQUASHFS) += squashfs.o
+squashfs-y += inode.o
+squashfs-y += squashfs2_0.o
-diff -urN linux-2.6.22.4/fs/squashfs/squashfs2_0.c linux-2.6.22.4-squashfs/fs/squashfs/squashfs2_0.c
---- linux-2.6.22.4/fs/squashfs/squashfs2_0.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.22.4-squashfs/fs/squashfs/squashfs2_0.c 2007-09-20 19:13:44.000000000 +0200
+Index: linux-2.6.22.19/fs/squashfs/squashfs2_0.c
+===================================================================
+--- /dev/null
++++ linux-2.6.22.19/fs/squashfs/squashfs2_0.c
@@ -0,0 +1,758 @@
+/*
+ * Squashfs - a compressed read only filesystem for Linux
@@ -2983,9 +2988,10 @@ diff -urN linux-2.6.22.4/fs/squashfs/squashfs2_0.c linux-2.6.22.4-squashfs/fs/sq
+
+ return 1;
+}
-diff -urN linux-2.6.22.4/fs/squashfs/squashfs.h linux-2.6.22.4-squashfs/fs/squashfs/squashfs.h
---- linux-2.6.22.4/fs/squashfs/squashfs.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.22.4-squashfs/fs/squashfs/squashfs.h 2007-09-20 19:13:44.000000000 +0200
+Index: linux-2.6.22.19/fs/squashfs/squashfs.h
+===================================================================
+--- /dev/null
++++ linux-2.6.22.19/fs/squashfs/squashfs.h
@@ -0,0 +1,86 @@
+/*
+ * Squashfs - a compressed read only filesystem for Linux
@@ -3073,9 +3079,10 @@ diff -urN linux-2.6.22.4/fs/squashfs/squashfs.h linux-2.6.22.4-squashfs/fs/squas
+ return 0;
+}
+#endif
-diff -urN linux-2.6.22.4/include/linux/magic.h linux-2.6.22.4-squashfs/include/linux/magic.h
---- linux-2.6.22.4/include/linux/magic.h 2007-08-21 06:33:06.000000000 +0200
-+++ linux-2.6.22.4-squashfs/include/linux/magic.h 2007-09-20 19:15:43.000000000 +0200
+Index: linux-2.6.22.19/include/linux/magic.h
+===================================================================
+--- linux-2.6.22.19.orig/include/linux/magic.h
++++ linux-2.6.22.19/include/linux/magic.h
@@ -36,6 +36,9 @@
#define REISER2FS_SUPER_MAGIC_STRING "ReIsEr2Fs"
#define REISER2FS_JR_SUPER_MAGIC_STRING "ReIsEr3Fs"
@@ -3086,9 +3093,10 @@ diff -urN linux-2.6.22.4/include/linux/magic.h linux-2.6.22.4-squashfs/include/l
#define SMB_SUPER_MAGIC 0x517B
#define USBDEVICE_SUPER_MAGIC 0x9fa2
-diff -urN linux-2.6.22.4/include/linux/squashfs_fs.h linux-2.6.22.4-squashfs/include/linux/squashfs_fs.h
---- linux-2.6.22.4/include/linux/squashfs_fs.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.22.4-squashfs/include/linux/squashfs_fs.h 2007-09-20 19:15:01.000000000 +0200
+Index: linux-2.6.22.19/include/linux/squashfs_fs.h
+===================================================================
+--- /dev/null
++++ linux-2.6.22.19/include/linux/squashfs_fs.h
@@ -0,0 +1,911 @@
+#ifndef SQUASHFS_FS
+#define SQUASHFS_FS
@@ -4001,9 +4009,10 @@ diff -urN linux-2.6.22.4/include/linux/squashfs_fs.h linux-2.6.22.4-squashfs/inc
+
+#endif
+#endif
-diff -urN linux-2.6.22.4/include/linux/squashfs_fs_i.h linux-2.6.22.4-squashfs/include/linux/squashfs_fs_i.h
---- linux-2.6.22.4/include/linux/squashfs_fs_i.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.22.4-squashfs/include/linux/squashfs_fs_i.h 2007-09-20 19:13:44.000000000 +0200
+Index: linux-2.6.22.19/include/linux/squashfs_fs_i.h
+===================================================================
+--- /dev/null
++++ linux-2.6.22.19/include/linux/squashfs_fs_i.h
@@ -0,0 +1,45 @@
+#ifndef SQUASHFS_FS_I
+#define SQUASHFS_FS_I
@@ -4050,9 +4059,10 @@ diff -urN linux-2.6.22.4/include/linux/squashfs_fs_i.h linux-2.6.22.4-squashfs/i
+ struct inode vfs_inode;
+};
+#endif
-diff -urN linux-2.6.22.4/include/linux/squashfs_fs_sb.h linux-2.6.22.4-squashfs/include/linux/squashfs_fs_sb.h
---- linux-2.6.22.4/include/linux/squashfs_fs_sb.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.22.4-squashfs/include/linux/squashfs_fs_sb.h 2007-09-20 19:13:44.000000000 +0200
+Index: linux-2.6.22.19/include/linux/squashfs_fs_sb.h
+===================================================================
+--- /dev/null
++++ linux-2.6.22.19/include/linux/squashfs_fs_sb.h
@@ -0,0 +1,74 @@
+#ifndef SQUASHFS_FS_SB
+#define SQUASHFS_FS_SB
@@ -4128,9 +4138,10 @@ diff -urN linux-2.6.22.4/include/linux/squashfs_fs_sb.h linux-2.6.22.4-squashfs/
+ int (*read_fragment_index_table)(struct super_block *s);
+};
+#endif
-diff -urN linux-2.6.22.4/init/do_mounts_rd.c linux-2.6.22.4-squashfs/init/do_mounts_rd.c
---- linux-2.6.22.4/init/do_mounts_rd.c 2007-08-21 06:33:06.000000000 +0200
-+++ linux-2.6.22.4-squashfs/init/do_mounts_rd.c 2007-09-20 19:13:44.000000000 +0200
+Index: linux-2.6.22.19/init/do_mounts_rd.c
+===================================================================
+--- linux-2.6.22.19.orig/init/do_mounts_rd.c
++++ linux-2.6.22.19/init/do_mounts_rd.c
@@ -5,6 +5,7 @@
#include <linux/ext2_fs.h>
#include <linux/romfs_fs.h>
@@ -4139,7 +4150,7 @@ diff -urN linux-2.6.22.4/init/do_mounts_rd.c linux-2.6.22.4-squashfs/init/do_mou
#include <linux/initrd.h>
#include <linux/string.h>
-@@ -39,6 +40,7 @@
+@@ -39,6 +40,7 @@ static int __init crd_load(int in_fd, in
* numbers could not be found.
*
* We currently check for the following magic numbers:
@@ -4147,7 +4158,7 @@ diff -urN linux-2.6.22.4/init/do_mounts_rd.c linux-2.6.22.4-squashfs/init/do_mou
* minix
* ext2
* romfs
-@@ -53,6 +55,7 @@
+@@ -53,6 +55,7 @@ identify_ramdisk_image(int fd, int start
struct ext2_super_block *ext2sb;
struct romfs_super_block *romfsb;
struct cramfs_super *cramfsb;
@@ -4155,7 +4166,7 @@ diff -urN linux-2.6.22.4/init/do_mounts_rd.c linux-2.6.22.4-squashfs/init/do_mou
int nblocks = -1;
unsigned char *buf;
-@@ -64,6 +67,7 @@
+@@ -64,6 +67,7 @@ identify_ramdisk_image(int fd, int start
ext2sb = (struct ext2_super_block *) buf;
romfsb = (struct romfs_super_block *) buf;
cramfsb = (struct cramfs_super *) buf;
@@ -4163,7 +4174,7 @@ diff -urN linux-2.6.22.4/init/do_mounts_rd.c linux-2.6.22.4-squashfs/init/do_mou
memset(buf, 0xe5, size);
/*
-@@ -101,6 +105,15 @@
+@@ -101,6 +105,15 @@ identify_ramdisk_image(int fd, int start
goto done;
}