summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
commit29e1ac054cebd1b0309aaa1465bb04ebcad5d858 (patch)
tree7732dd7b35dd81e1c50f9b718b6112e6503c4e9b /target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
parent1200d62f668a1eac3123301eee1fc96613133409 (diff)
downloadmaster-31e0f0ae-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.tar.gz
master-31e0f0ae-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.tar.bz2
master-31e0f0ae-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.zip
generic-2.6/2.6.21: refresh patches
SVN-Revision: 14453
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch16
1 files changed, 5 insertions, 11 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
index a686bd3d6f..bc86a94fe4 100644
--- a/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/net/netfilter/Kconfig
-+++ linux-2.6.21.7/net/netfilter/Kconfig
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
@@ -414,6 +414,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
To compile it as a module, choose M here. If unsure, say N.
@@ -26,10 +24,8 @@ Index: linux-2.6.21.7/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.21.7/net/netfilter/Makefile
-===================================================================
---- linux-2.6.21.7.orig/net/netfilter/Makefile
-+++ linux-2.6.21.7/net/netfilter/Makefile
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
@@ -45,6 +45,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) += xt_NFLOG.o
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
@@ -38,10 +34,8 @@ Index: linux-2.6.21.7/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-Index: linux-2.6.21.7/net/netfilter/xt_TARPIT.c
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/net/netfilter/xt_TARPIT.c
++++ b/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,280 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using