summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
commit29e1ac054cebd1b0309aaa1465bb04ebcad5d858 (patch)
tree7732dd7b35dd81e1c50f9b718b6112e6503c4e9b /target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch
parent1200d62f668a1eac3123301eee1fc96613133409 (diff)
downloadmaster-31e0f0ae-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.tar.gz
master-31e0f0ae-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.tar.bz2
master-31e0f0ae-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.zip
generic-2.6/2.6.21: refresh patches
SVN-Revision: 14453
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch20
1 files changed, 6 insertions, 14 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch b/target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch
index f1feaf6c0d..ad12030c33 100644
--- a/target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch
+++ b/target/linux/generic-2.6/patches-2.6.21/140-netfilter_time.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_time.h
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_time.h
++++ b/include/linux/netfilter_ipv4/ipt_time.h
@@ -0,0 +1,18 @@
+#ifndef __ipt_time_h_included__
+#define __ipt_time_h_included__
@@ -21,10 +19,8 @@ Index: linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_time.h
+
+
+#endif /* __ipt_time_h_included__ */
-Index: linux-2.6.21.7/net/ipv4/netfilter/ipt_time.c
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/net/ipv4/netfilter/ipt_time.c
++++ b/net/ipv4/netfilter/ipt_time.c
@@ -0,0 +1,178 @@
+/*
+ This is a module which is used for time matching
@@ -204,10 +200,8 @@ Index: linux-2.6.21.7/net/ipv4/netfilter/ipt_time.c
+ r->tm_mon=i;
+ r->tm_mday=work-__spm[i]+1;
+}
-Index: linux-2.6.21.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.21.7/net/ipv4/netfilter/Kconfig
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
@@ -260,6 +260,22 @@ config IP_NF_MATCH_TOS
To compile it as a module, choose M here. If unsure, say N.
@@ -231,10 +225,8 @@ Index: linux-2.6.21.7/net/ipv4/netfilter/Kconfig
config IP_NF_MATCH_RECENT
tristate "recent match support"
depends on IP_NF_IPTABLES
-Index: linux-2.6.21.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.21.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.21.7/net/ipv4/netfilter/Makefile
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
@@ -86,6 +86,7 @@ obj-$(CONFIG_IP_NF_RAW) += iptable_raw.o
obj-$(CONFIG_IP_NF_MATCH_IPRANGE) += ipt_iprange.o
obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_owner.o