summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/image/lzma-loader
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-03-26 13:33:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-03-26 13:33:22 +0000
commit6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27 (patch)
tree23c281ee776a9563e330d7ab06ed0663b63c379c /target/linux/generic-2.6/image/lzma-loader
parentb96aec3f500279b9eeb7e08e35a64774810a4aea (diff)
downloadmaster-31e0f0ae-6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27.tar.gz
master-31e0f0ae-6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27.tar.bz2
master-31e0f0ae-6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27.zip
Generate a binary lzma-loader
SVN-Revision: 10661
Diffstat (limited to 'target/linux/generic-2.6/image/lzma-loader')
-rw-r--r--target/linux/generic-2.6/image/lzma-loader/Makefile6
-rw-r--r--target/linux/generic-2.6/image/lzma-loader/src/Makefile7
2 files changed, 10 insertions, 3 deletions
diff --git a/target/linux/generic-2.6/image/lzma-loader/Makefile b/target/linux/generic-2.6/image/lzma-loader/Makefile
index e3a98afbce..171c3c3938 100644
--- a/target/linux/generic-2.6/image/lzma-loader/Makefile
+++ b/target/linux/generic-2.6/image/lzma-loader/Makefile
@@ -33,11 +33,15 @@ $(PKG_BUILD_DIR)/vmlinux.lzma: $(KDIR)/vmlinux.lzma
$(KDIR)/loader$(LOADER_TYPE).elf: $(PKG_BUILD_DIR)/lzma.elf
$(CP) $< $@
+$(KDIR)/loader$(LOADER_TYPE).bin: $(PKG_BUILD_DIR)/lzma.bin
+ $(CP) $< $@
+
download:
prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(KDIR)/loader$(LOADER_TYPE).elf
+compile: $(KDIR)/loader$(LOADER_TYPE).elf $(KDIR)/loader$(LOADER_TYPE).bin
install:
clean:
rm -rf $(PKG_BUILD_DIR)
rm -f $(KDIR)/loader.elf
+ rm -f $(KDIR)/loader.bin
diff --git a/target/linux/generic-2.6/image/lzma-loader/src/Makefile b/target/linux/generic-2.6/image/lzma-loader/src/Makefile
index 13ed96213e..910172c4f8 100644
--- a/target/linux/generic-2.6/image/lzma-loader/src/Makefile
+++ b/target/linux/generic-2.6/image/lzma-loader/src/Makefile
@@ -36,7 +36,7 @@ O_FORMAT = $(shell $(OBJDUMP) -i | head -2 | grep elf32)
drop-sections = .reginfo .mdebug .comment
strip-flags = $(addprefix --remove-section=,$(drop-sections))
-all : lzma.elf
+all : lzma.elf lzma.bin
lzma.lds: lzma.lds.in
sed -e 's,@LOADADDR@,$(LOADADDR),g' -e 's,@ENTRY@,_start,g' $< >$@
@@ -44,6 +44,9 @@ lzma.lds: lzma.lds.in
kernel.o: vmlinux.lzma lzma.lds
$(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
+lzma.bin: lzma.elf
+ $(OBJCOPY) $< $@
+
ifeq ($(IMAGE_COPY),1)
LOADER_ENTRY ?= $(KERNEL_ENTRY)
lzma.o: decompress.o LzmaDecode.o kernel.o
@@ -62,4 +65,4 @@ lzma.elf: start.o decompress.o LzmaDecode.o kernel.o
endif
clean:
- rm -f *.o lzma.elf *.tmp *.lds
+ rm -f *.o lzma.elf lzma.bin *.tmp *.lds