summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/files/drivers/ssb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
commit1e570a9288856bcd288a80115f2233c9c785706c (patch)
tree8491af08bde47e22f96c01e6f560206b3fd02a4a /target/linux/generic-2.6/files/drivers/ssb/Makefile
parent487c622ac0c37f3cd26add56df9081ea7caf3835 (diff)
downloadmaster-31e0f0ae-1e570a9288856bcd288a80115f2233c9c785706c.tar.gz
master-31e0f0ae-1e570a9288856bcd288a80115f2233c9c785706c.tar.bz2
master-31e0f0ae-1e570a9288856bcd288a80115f2233c9c785706c.zip
change the way ./files* and the generic kernel files are applied. ./files now applies to *ALL* kernel versions, and is copied along with ./files-* - this gets rid of quite a bit of redundancy in the extra kernel drivers.
SVN-Revision: 13010
Diffstat (limited to 'target/linux/generic-2.6/files/drivers/ssb/Makefile')
-rw-r--r--target/linux/generic-2.6/files/drivers/ssb/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/target/linux/generic-2.6/files/drivers/ssb/Makefile b/target/linux/generic-2.6/files/drivers/ssb/Makefile
deleted file mode 100644
index 7be3975958..0000000000
--- a/target/linux/generic-2.6/files/drivers/ssb/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-# core
-ssb-y += main.o scan.o
-
-# host support
-ssb-$(CONFIG_SSB_PCIHOST) += pci.o pcihost_wrapper.o
-ssb-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
-
-# built-in drivers
-ssb-y += driver_chipcommon.o
-ssb-$(CONFIG_SSB_DRIVER_MIPS) += driver_mipscore.o
-ssb-$(CONFIG_SSB_DRIVER_EXTIF) += driver_extif.o
-ssb-$(CONFIG_SSB_DRIVER_PCICORE) += driver_pcicore.o
-
-# b43 pci-ssb-bridge driver
-# Not strictly a part of SSB, but kept here for convenience
-ssb-$(CONFIG_SSB_PCIHOST) += b43_pci_bridge.o
-
-obj-$(CONFIG_SSB) += ssb.o