summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/621-netfilter_random.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
committerNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
commit0e43e71159f1febb4926a4f4d56c60edc2cf0ebd (patch)
tree18bc80caa116785a9a729eddf7d67b5585f5a844 /target/linux/generic-2.4/patches/621-netfilter_random.patch
parentc9b0c63f0758f9d0f96846f0cdac3f167ba22b36 (diff)
downloadmaster-31e0f0ae-0e43e71159f1febb4926a4f4d56c60edc2cf0ebd.tar.gz
master-31e0f0ae-0e43e71159f1febb4926a4f4d56c60edc2cf0ebd.tar.bz2
master-31e0f0ae-0e43e71159f1febb4926a4f4d56c60edc2cf0ebd.zip
remove ipset support from core, it is now provided by xtables-addons from the packages feed
SVN-Revision: 17844
Diffstat (limited to 'target/linux/generic-2.4/patches/621-netfilter_random.patch')
-rw-r--r--target/linux/generic-2.4/patches/621-netfilter_random.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic-2.4/patches/621-netfilter_random.patch b/target/linux/generic-2.4/patches/621-netfilter_random.patch
index 2f47db36ca..fbc648b1bc 100644
--- a/target/linux/generic-2.4/patches/621-netfilter_random.patch
+++ b/target/linux/generic-2.4/patches/621-netfilter_random.patch
@@ -24,7 +24,7 @@
TCPMSS match support
CONFIG_IP_NF_MATCH_TCPMSS
This option adds a `tcpmss' match, which allows you to examine the
-@@ -3387,6 +3397,14 @@ CONFIG_IP6_NF_MATCH_MAC
+@@ -3318,6 +3328,14 @@ CONFIG_IP6_NF_MATCH_MAC
If you want to compile it as a module, say M here and read
<file:Documentation/modules.txt>. If unsure, say `N'.
@@ -69,7 +69,7 @@
+#endif /*_IP6T_RAND_H*/
--- a/net/ipv4/netfilter/Config.in
+++ b/net/ipv4/netfilter/Config.in
-@@ -46,6 +46,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
+@@ -32,6 +32,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
dep_tristate ' netfilter MARK match support' CONFIG_IP_NF_MATCH_MARK $CONFIG_IP_NF_IPTABLES
dep_tristate ' Multiple port match support' CONFIG_IP_NF_MATCH_MULTIPORT $CONFIG_IP_NF_IPTABLES
dep_tristate ' TOS match support' CONFIG_IP_NF_MATCH_TOS $CONFIG_IP_NF_IPTABLES
@@ -178,7 +178,7 @@
+module_exit(fini);
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -105,6 +105,8 @@ obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_o
+@@ -93,6 +93,8 @@ obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_o
obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
obj-$(CONFIG_IP_NF_MATCH_CONDITION) += ipt_condition.o