summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2009-05-15 10:36:04 +0000
committerAndy Boyett <agb@openwrt.org>2009-05-15 10:36:04 +0000
commit88e632d853ac18fc82ef245486ed952ef124739c (patch)
tree21c2c051c41c9aa3cc6edb39362386b75b78643b /target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch
parent94921686de5f1ded59d5b3bc79812b31bf4fca48 (diff)
downloadmaster-31e0f0ae-88e632d853ac18fc82ef245486ed952ef124739c.tar.gz
master-31e0f0ae-88e632d853ac18fc82ef245486ed952ef124739c.tar.bz2
master-31e0f0ae-88e632d853ac18fc82ef245486ed952ef124739c.zip
generic-2.4: refresh patches
SVN-Revision: 15860
Diffstat (limited to 'target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch')
-rw-r--r--target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch30
1 files changed, 9 insertions, 21 deletions
diff --git a/target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch b/target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch
index 996b21fb4b..cb23abde6d 100644
--- a/target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch
+++ b/target/linux/generic-2.4/patches/613-netfilter_nat_h323.patch
@@ -1,7 +1,5 @@
-Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in
-+++ linux-2.4.35.4/net/ipv4/netfilter/Config.in
+--- a/net/ipv4/netfilter/Config.in
++++ b/net/ipv4/netfilter/Config.in
@@ -15,6 +15,7 @@ if [ "$CONFIG_IP_NF_CONNTRACK" != "n" ];
dep_tristate ' Connection byte counter support' CONFIG_IP_NF_MATCH_CONNBYTES $CONFIG_IP_NF_CT_ACCT $CONFIG_IP_NF_CONNTRACK $CONFIG_IP_NF_IPTABLES
dep_tristate ' GRE protocol support' CONFIG_IP_NF_CT_PROTO_GRE $CONFIG_IP_NF_CONNTRACK
@@ -24,10 +22,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
dep_tristate ' Basic SNMP-ALG support (EXPERIMENTAL)' CONFIG_IP_NF_NAT_SNMP_BASIC $CONFIG_IP_NF_NAT
fi
-Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.4.35.4/net/ipv4/netfilter/Makefile
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
@@ -53,6 +53,10 @@ obj-$(CONFIG_IP_NF_PPTP) += ip_conntrack
ifdef CONFIG_IP_NF_NAT_PPTP
export-objs += ip_conntrack_pptp.o
@@ -47,10 +43,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
# generic IP tables
obj-$(CONFIG_IP_NF_IPTABLES) += ip_tables.o
-Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_h323.c
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_h323.c
++++ b/net/ipv4/netfilter/ip_conntrack_h323.c
@@ -0,0 +1,302 @@
+/*
+ * H.323 'brute force' extension for H.323 connection tracking.
@@ -354,10 +348,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_h323.c
+
+module_init(init);
+module_exit(fini);
-Index: linux-2.4.35.4/net/ipv4/netfilter/ip_nat_h323.c
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_nat_h323.c
++++ b/net/ipv4/netfilter/ip_nat_h323.c
@@ -0,0 +1,403 @@
+/*
+ * H.323 'brute force' extension for NAT alteration.
@@ -762,10 +754,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_nat_h323.c
+
+module_init(init);
+module_exit(fini);
-Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
-===================================================================
---- linux-2.4.35.4.orig/include/linux/netfilter_ipv4/ip_conntrack.h
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
+--- a/include/linux/netfilter_ipv4/ip_conntrack.h
++++ b/include/linux/netfilter_ipv4/ip_conntrack.h
@@ -71,6 +71,7 @@ union ip_conntrack_expect_proto {
#include <linux/netfilter_ipv4/ip_conntrack_ftp.h>
#include <linux/netfilter_ipv4/ip_conntrack_irc.h>
@@ -790,10 +780,8 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
};
#ifdef CONFIG_IP_NF_NAT_NEEDED
-Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack_h323.h
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack_h323.h
++++ b/include/linux/netfilter_ipv4/ip_conntrack_h323.h
@@ -0,0 +1,30 @@
+#ifndef _IP_CONNTRACK_H323_H
+#define _IP_CONNTRACK_H323_H