summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/files/crypto/ocf/cryptocteon/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:00:14 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:00:14 +0000
commit0ff83e90ba5f0ed1d900813b470f61527500fdd8 (patch)
tree24468146cc7991ce8fa77e110d197a03582501bc /target/linux/generic-2.4/files/crypto/ocf/cryptocteon/Makefile
parent32e7340bf26d1d59aefb14bf1af4c2e3cb9a9642 (diff)
downloadmaster-31e0f0ae-0ff83e90ba5f0ed1d900813b470f61527500fdd8.tar.gz
master-31e0f0ae-0ff83e90ba5f0ed1d900813b470f61527500fdd8.tar.bz2
master-31e0f0ae-0ff83e90ba5f0ed1d900813b470f61527500fdd8.zip
add OCF 20100325 support to brcm-2.4
SVN-Revision: 21357
Diffstat (limited to 'target/linux/generic-2.4/files/crypto/ocf/cryptocteon/Makefile')
-rw-r--r--target/linux/generic-2.4/files/crypto/ocf/cryptocteon/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/generic-2.4/files/crypto/ocf/cryptocteon/Makefile b/target/linux/generic-2.4/files/crypto/ocf/cryptocteon/Makefile
new file mode 100644
index 0000000000..eeed0d6411
--- /dev/null
+++ b/target/linux/generic-2.4/files/crypto/ocf/cryptocteon/Makefile
@@ -0,0 +1,17 @@
+# for SGlinux builds
+-include $(ROOTDIR)/modules/.config
+
+obj-$(CONFIG_OCF_CRYPTOCTEON) += cryptocteon.o
+
+obj ?= .
+EXTRA_CFLAGS += -I$(obj)/.. -I$(obj)/
+
+ifdef CONFIG_OCF_CRYPTOCTEON
+# you need the cavium crypto component installed
+EXTRA_CFLAGS += -I$(ROOTDIR)/prop/include
+endif
+
+ifdef TOPDIR
+-include $(TOPDIR)/Rules.make
+endif
+