summaryrefslogtreecommitdiffstats
path: root/target/linux/gemini
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-29 11:28:33 +0000
committerJohn Crispin <john@openwrt.org>2015-05-29 11:28:33 +0000
commit1985e88b359d5f343cb45cba6bd27698b8e81e92 (patch)
tree9c66c4eb1455a3d4859d22991831106cef98c964 /target/linux/gemini
parent9927a9a5f86740aee34b730feb810d4292a0ed53 (diff)
downloadmaster-31e0f0ae-1985e88b359d5f343cb45cba6bd27698b8e81e92.tar.gz
master-31e0f0ae-1985e88b359d5f343cb45cba6bd27698b8e81e92.tar.bz2
master-31e0f0ae-1985e88b359d5f343cb45cba6bd27698b8e81e92.zip
gemini: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45822
Diffstat (limited to 'target/linux/gemini')
-rw-r--r--target/linux/gemini/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 80fb59e249..7ed1d61f30 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -21,8 +21,8 @@ endif
ifeq ($(SUBTARGET),raidsonic)
define Image/Prepare
# NAS4220: mach id 2038 (0x7F6)
- echo -en "\x07\x1c\xa0\xe3\xf6\x10\x81\xe3" > $(BIN_DIR)/$(IMG_PREFIX)-nas4220-zImage
- cat $(KDIR)/zImage >> $(BIN_DIR)/$(IMG_PREFIX)-nas4220-zImage
+ echo -en "\x07\x1c\xa0\xe3\xf6\x10\x81\xe3" > $(KDIR)/$(IMG_PREFIX)-nas4220-zImage
+ cat $(KDIR)/zImage >> $(KDIR)/$(IMG_PREFIX)-nas4220-zImage
endef
endif
@@ -74,7 +74,7 @@ define Image/Build
dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img of=$(BIN_DIR)/rd.gz bs=6144k count=1
# dd if=/dev/zero of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1
dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
- cp $(BIN_DIR)/$(IMG_PREFIX)-nas4220-zImage $(BIN_DIR)/zImage
+ cp $(KDIR)/$(IMG_PREFIX)-nas4220-zImage $(BIN_DIR)/zImage
cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
(cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220-rd.gz