summaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-13 10:59:59 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-13 10:59:59 +0000
commit92353181b56770605d7c0a50a21f0f98d66f29b6 (patch)
treeda3302a30c90ffcd18881bc9a9571cd2038e1507 /target/linux/gemini/image
parentf8c315bb603c42367cdd2ccaf126f321d3a0a706 (diff)
downloadmaster-31e0f0ae-92353181b56770605d7c0a50a21f0f98d66f29b6.tar.gz
master-31e0f0ae-92353181b56770605d7c0a50a21f0f98d66f29b6.tar.bz2
master-31e0f0ae-92353181b56770605d7c0a50a21f0f98d66f29b6.zip
workaround a bootloader bug on the WBD111
SVN-Revision: 15818
Diffstat (limited to 'target/linux/gemini/image')
-rw-r--r--target/linux/gemini/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 6fb7750649..fc69ffcc81 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -14,7 +14,9 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/openwrt-$(BOARD)-wbd111-zImage $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+# workaround the bootloader's bug with extra nops
+ echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+ cat $(KDIR)/openwrt-$(BOARD)-wbd111-zImage >> $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
endef
define Image/Build/jffs2-64k