summaryrefslogtreecommitdiffstats
path: root/target/linux/etrax/patches
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-05-03 20:57:59 +0000
committerJohn Crispin <john@openwrt.org>2008-05-03 20:57:59 +0000
commit81f207d663bb0742887dc058b801080fa92f72d8 (patch)
treedbeb210b624ecc95dd2a915ac9726fa5ebf89ded /target/linux/etrax/patches
parent1dce440fa58b8ea11cca833d434584e3935c83fe (diff)
downloadmaster-31e0f0ae-81f207d663bb0742887dc058b801080fa92f72d8.tar.gz
master-31e0f0ae-81f207d663bb0742887dc058b801080fa92f72d8.tar.bz2
master-31e0f0ae-81f207d663bb0742887dc058b801080fa92f72d8.zip
add etrax usb driver
SVN-Revision: 11039
Diffstat (limited to 'target/linux/etrax/patches')
-rw-r--r--target/linux/etrax/patches/301-usb_support.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/etrax/patches/301-usb_support.patch b/target/linux/etrax/patches/301-usb_support.patch
new file mode 100644
index 0000000000..3bc9f2366e
--- /dev/null
+++ b/target/linux/etrax/patches/301-usb_support.patch
@@ -0,0 +1,22 @@
+Index: linux-2.6.25.1/drivers/usb/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/usb/Makefile 2008-05-03 21:33:11.000000000 +0100
++++ linux-2.6.25.1/drivers/usb/Makefile 2008-05-03 21:33:17.000000000 +0100
+@@ -16,6 +16,7 @@
+ obj-$(CONFIG_USB_SL811_HCD) += host/
+ obj-$(CONFIG_USB_U132_HCD) += host/
+ obj-$(CONFIG_USB_R8A66597_HCD) += host/
++obj-$(CONFIG_ETRAX_USB_HOST) += host/
+
+ obj-$(CONFIG_USB_ACM) += class/
+ obj-$(CONFIG_USB_PRINTER) += class/
+Index: linux-2.6.25.1/drivers/usb/host/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/usb/host/Makefile 2008-05-03 21:33:24.000000000 +0100
++++ linux-2.6.25.1/drivers/usb/host/Makefile 2008-05-03 21:33:47.000000000 +0100
+@@ -16,4 +16,4 @@
+ obj-$(CONFIG_USB_SL811_CS) += sl811_cs.o
+ obj-$(CONFIG_USB_U132_HCD) += u132-hcd.o
+ obj-$(CONFIG_USB_R8A66597_HCD) += r8a66597-hcd.o
+-
++obj-$(CONFIG_ETRAX_ARCH_V10) += hc_crisv10.o