summaryrefslogtreecommitdiffstats
path: root/target/linux/etrax/patches/100-compile_fixes.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-05-03 17:38:13 +0000
committerJohn Crispin <john@openwrt.org>2008-05-03 17:38:13 +0000
commite199de8f01d8f5e108b6e209faee8e62300c0875 (patch)
tree9d6b01d15c2efa84ab5184473c8de830a8fb2e85 /target/linux/etrax/patches/100-compile_fixes.patch
parentae92bf4ae4178a30d1bc6e9b6dd58dca7c8ab37b (diff)
downloadmaster-31e0f0ae-e199de8f01d8f5e108b6e209faee8e62300c0875.tar.gz
master-31e0f0ae-e199de8f01d8f5e108b6e209faee8e62300c0875.tar.bz2
master-31e0f0ae-e199de8f01d8f5e108b6e209faee8e62300c0875.zip
bump etrax to .25.1
SVN-Revision: 11031
Diffstat (limited to 'target/linux/etrax/patches/100-compile_fixes.patch')
-rw-r--r--target/linux/etrax/patches/100-compile_fixes.patch63
1 files changed, 26 insertions, 37 deletions
diff --git a/target/linux/etrax/patches/100-compile_fixes.patch b/target/linux/etrax/patches/100-compile_fixes.patch
index 18c93d678f..d9eb5971d5 100644
--- a/target/linux/etrax/patches/100-compile_fixes.patch
+++ b/target/linux/etrax/patches/100-compile_fixes.patch
@@ -1,32 +1,7 @@
-Index: linux-2.6.25.1/arch/cris/mm/init.c
+Index: linux-2.6.25.1/arch/cris/arch-v10/boot/Makefile
===================================================================
---- linux-2.6.25.1.orig/arch/cris/mm/init.c 2008-05-03 09:53:53.000000000 +0100
-+++ linux-2.6.25.1/arch/cris/mm/init.c 2008-05-03 09:54:05.000000000 +0100
-@@ -112,3 +112,7 @@
- printk (KERN_INFO "Freeing unused kernel memory: %luk freed\n",
- (unsigned long)((&__init_end - &__init_begin) >> 10));
- }
-+
-+void free_initrd_mem(unsigned long start, unsigned long end)
-+{
-+}
-Index: linux-2.6.25.1/arch/cris/boot/compressed/Makefile
-===================================================================
---- linux-2.6.25.1.orig/arch/cris/boot/compressed/Makefile 2008-05-03 10:00:53.000000000 +0100
-+++ linux-2.6.25.1/arch/cris/boot/compressed/Makefile 2008-05-03 10:01:12.000000000 +0100
-@@ -7,7 +7,7 @@
- LD = ld-cris
- ldflags-y += -T $(obj)/decompress.ld
- OBJECTS = $(obj)/head.o $(obj)/misc.o
--OBJCOPY = objcopy-cris
-+OBJCOPY = /usr/local/cris/objcopy-cris
- OBJCOPYFLAGS = -O binary --remove-section=.bss
-
- quiet_cmd_image = BUILD $@
-Index: linux-2.6.25.1/arch/cris/boot/Makefile
-===================================================================
---- linux-2.6.25.1.orig/arch/cris/boot/Makefile 2008-04-17 03:49:44.000000000 +0100
-+++ linux-2.6.25.1/arch/cris/boot/Makefile 2008-05-03 10:05:56.000000000 +0100
+--- linux-2.6.25.1.orig/arch/cris/arch-v10/boot/Makefile 2008-05-03 18:16:00.000000000 +0100
++++ linux-2.6.25.1/arch/cris/arch-v10/boot/Makefile 2008-05-03 18:16:12.000000000 +0100
@@ -2,10 +2,10 @@
# arch/cris/arch-v10/boot/Makefile
#
@@ -48,11 +23,11 @@ Index: linux-2.6.25.1/arch/cris/boot/Makefile
$(obj)/zImage: $(obj)/compressed/vmlinux
@cp $< $@
-Index: linux-2.6.25.1/arch/cris/boot/compressed/Makefile
+Index: linux-2.6.25.1/arch/cris/arch-v10/boot/compressed/Makefile
===================================================================
---- linux-2.6.25.1.orig/arch/cris/boot/compressed/Makefile 2008-05-03 10:01:12.000000000 +0100
-+++ linux-2.6.25.1/arch/cris/boot/compressed/Makefile 2008-05-03 16:29:55.000000000 +0100
-@@ -2,9 +2,8 @@
+--- linux-2.6.25.1.orig/arch/cris/arch-v10/boot/compressed/Makefile 2008-05-03 18:16:00.000000000 +0100
++++ linux-2.6.25.1/arch/cris/arch-v10/boot/compressed/Makefile 2008-05-03 18:16:12.000000000 +0100
+@@ -2,12 +2,11 @@
# arch/cris/arch-v10/boot/compressed/Makefile
#
@@ -62,7 +37,11 @@ Index: linux-2.6.25.1/arch/cris/boot/compressed/Makefile
+LD=/usr/local/cris/ld-cris
ldflags-y += -T $(obj)/decompress.ld
OBJECTS = $(obj)/head.o $(obj)/misc.o
- OBJCOPY = /usr/local/cris/objcopy-cris
+-OBJCOPY = objcopy-cris
++OBJCOPY = /usr/local/cris/objcopy-cris
+ OBJCOPYFLAGS = -O binary --remove-section=.bss
+
+ quiet_cmd_image = BUILD $@
@@ -22,10 +21,10 @@
$(call if_changed,objcopy)
@@ -76,10 +55,10 @@ Index: linux-2.6.25.1/arch/cris/boot/compressed/Makefile
$(obj)/vmlinux: $(obj)/piggy.gz $(obj)/decompress.bin FORCE
$(call if_changed,image)
-Index: linux-2.6.25.1/arch/cris/boot/compressed/misc.c
+Index: linux-2.6.25.1/arch/cris/arch-v10/boot/compressed/misc.c
===================================================================
---- linux-2.6.25.1.orig/arch/cris/boot/compressed/misc.c 2008-05-03 16:22:44.000000000 +0100
-+++ linux-2.6.25.1/arch/cris/boot/compressed/misc.c 2008-05-03 16:23:26.000000000 +0100
+--- linux-2.6.25.1.orig/arch/cris/arch-v10/boot/compressed/misc.c 2008-05-03 18:16:00.000000000 +0100
++++ linux-2.6.25.1/arch/cris/arch-v10/boot/compressed/misc.c 2008-05-03 18:16:12.000000000 +0100
@@ -5,7 +5,7 @@
* adapted for Linux.
*
@@ -120,7 +99,7 @@ Index: linux-2.6.25.1/arch/cris/boot/compressed/misc.c
while(1); /* Halt */
}
-@@ -25.17,14 +25.17,7 @@
+@@ -257,14 +257,7 @@
makecrc();
@@ -137,3 +116,13 @@ Index: linux-2.6.25.1/arch/cris/boot/compressed/misc.c
- puts("Done. Now booting the kernel.\n");
+ putstr("Done. Now booting the kernel.\n");
}
+Index: linux-2.6.25.1/arch/cris/arch-v10/mm/init.c
+===================================================================
+--- linux-2.6.25.1.orig/arch/cris/arch-v10/mm/init.c 2008-05-03 18:18:51.000000000 +0100
++++ linux-2.6.25.1/arch/cris/arch-v10/mm/init.c 2008-05-03 18:18:53.000000000 +0100
+@@ -113,3 +113,6 @@
+ (unsigned long)((&__init_end - &__init_begin) >> 10));
+ }
++void free_initrd_mem(unsigned long start, unsigned long end)
++{
++}