summaryrefslogtreecommitdiffstats
path: root/target/linux/ep93xx/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-11-25 23:43:48 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-11-25 23:43:48 +0000
commit4bfa2947eeca220e3cff41dbad9fbaea25245ed0 (patch)
treebb7af150cb3f5cd5c354b5bcdeb00eb1f235b940 /target/linux/ep93xx/Makefile
parent850fe2320fc1056b45aab08bbac8e3a3da806203 (diff)
downloadmaster-31e0f0ae-4bfa2947eeca220e3cff41dbad9fbaea25245ed0.tar.gz
master-31e0f0ae-4bfa2947eeca220e3cff41dbad9fbaea25245ed0.tar.bz2
master-31e0f0ae-4bfa2947eeca220e3cff41dbad9fbaea25245ed0.zip
add support for the Simplemachines Sim.One board
SVN-Revision: 18540
Diffstat (limited to 'target/linux/ep93xx/Makefile')
-rw-r--r--target/linux/ep93xx/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ep93xx/Makefile b/target/linux/ep93xx/Makefile
new file mode 100644
index 0000000000..a43855ed18
--- /dev/null
+++ b/target/linux/ep93xx/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=ep93xx
+BOARDNAME:=Cirrus Logic EP93xx SoC
+FEATURES:=squashfs jffs2 ext2 tgz
+CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
+
+LINUX_VERSION:=2.6.30.9
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+$(eval $(call BuildTarget))