summaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/image/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/coldfire/image/Makefile
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadmaster-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/coldfire/image/Makefile')
-rw-r--r--target/linux/coldfire/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/coldfire/image/Makefile b/target/linux/coldfire/image/Makefile
index 0228a8dcf6..94e28b2cbb 100644
--- a/target/linux/coldfire/image/Makefile
+++ b/target/linux/coldfire/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -17,7 +17,7 @@ define Image/BuildKernel
-R .note.gnu.build-id -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.bin
mkimage -A m68k -O linux -T kernel -a 0x00020000 -e 0x00020000 \
-C none -n 'M68K OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux.bin $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ -d $(KDIR)/vmlinux.bin $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
define Image/Build