summaryrefslogtreecommitdiffstats
path: root/target/linux/cobalt
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 14:01:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 14:01:49 +0000
commit03c06178e34418efc28b429018783869cda8350a (patch)
treef000054feaef44e598f2afad5a577e3f47fd37aa /target/linux/cobalt
parent83b7462ac918f8a8cc2c529086802a0843212aef (diff)
downloadmaster-31e0f0ae-03c06178e34418efc28b429018783869cda8350a.tar.gz
master-31e0f0ae-03c06178e34418efc28b429018783869cda8350a.tar.bz2
master-31e0f0ae-03c06178e34418efc28b429018783869cda8350a.zip
package buttons driver separately
SVN-Revision: 32841
Diffstat (limited to 'target/linux/cobalt')
-rw-r--r--target/linux/cobalt/config-3.34
-rw-r--r--target/linux/cobalt/modules.mk15
2 files changed, 15 insertions, 4 deletions
diff --git a/target/linux/cobalt/config-3.3 b/target/linux/cobalt/config-3.3
index ccc5839513..315ef15865 100644
--- a/target/linux/cobalt/config-3.3
+++ b/target/linux/cobalt/config-3.3
@@ -85,10 +85,6 @@ CONFIG_HZ=250
CONFIG_HZ_250=y
CONFIG_I8253=y
CONFIG_I8259=y
-CONFIG_INPUT=y
-CONFIG_INPUT_COBALT_BTNS=y
-CONFIG_INPUT_EVDEV=y
-CONFIG_INPUT_POLLDEV=y
# CONFIG_IP_ADVANCED_ROUTER is not set
# CONFIG_IP_MULTICAST is not set
CONFIG_IRQ_CPU=y
diff --git a/target/linux/cobalt/modules.mk b/target/linux/cobalt/modules.mk
index fcba757312..79cef87cac 100644
--- a/target/linux/cobalt/modules.mk
+++ b/target/linux/cobalt/modules.mk
@@ -19,3 +19,18 @@ define KernelPackage/fb-cobalt/descriptione
endef
$(eval $(call KernelPackage,fb-cobalt))
+
+define KernelPackage/cobalt-btns
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Cobalt buttons support
+ DEPENDS:=@TARGET_cobalt +kmod-input-evdev +kmod-input-polldev
+ KCONFIG:=CONFIG_INPUT_COBALT_BTNS
+ FILES:=$(LINUX_DIR)/drivers/input/misc/cobalt_btns.ko
+ AUTOLOAD:=$(call AutoLoad,62,cobalt_btns)
+endef
+
+define KernelPackage/cobalt-btns/description
+ Kernel module for the Cobalt Microservers buttons
+endef
+
+$(eval $(call KernelPackage,cobalt-btns))