summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit6a4f2922f6303a006d66b4bbb79541823b1c12b4 (patch)
treed3d9644c2a4a2e9b758bab9b84973e078143ed2c /target/linux/cns3xxx
parenteab95ea46736f8359c5a19a612f0e39160cab80c (diff)
downloadmaster-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.gz
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.bz2
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37049
Diffstat (limited to 'target/linux/cns3xxx')
-rw-r--r--target/linux/cns3xxx/Makefile2
-rw-r--r--target/linux/cns3xxx/image/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/cns3xxx/Makefile b/target/linux/cns3xxx/Makefile
index 4e8d6115f7..96d6ab137c 100644
--- a/target/linux/cns3xxx/Makefile
+++ b/target/linux/cns3xxx/Makefile
@@ -22,7 +22,7 @@ define Target/Description
eg. the Gateworks Laguna family
endef
-KERNELNAME:="uImage"
+KERNELNAME:="zImage uImage"
DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index 6f13fbaf60..7fa0b35e06 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define mkimage
- mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage-$(1)
+ mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage-$(1)
endef
define Image/Prepare