summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-10 09:57:07 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-10 09:57:07 +0000
commit28de84d0246eeb022fbc21cb765a0e4d47d15eb1 (patch)
tree4ee5d155fa883918adcedd30dcfee02e0dfa24be /target/linux/cns3xxx
parentb0fe7d1ec6d50862141d16b5dbe9ee41aa0f0c32 (diff)
downloadmaster-31e0f0ae-28de84d0246eeb022fbc21cb765a0e4d47d15eb1.tar.gz
master-31e0f0ae-28de84d0246eeb022fbc21cb765a0e4d47d15eb1.tar.bz2
master-31e0f0ae-28de84d0246eeb022fbc21cb765a0e4d47d15eb1.zip
add uImage image build
- add building of a standard uImage along with the combined kernel+rootfs - remove 'old' image build - that was for a very old and obsolete bootloader To update the bootloader for GW2387,GW2388,GW2391 (NOR Flash) from uboot: put latest NOR bootloader on tftp server: http://svn.gateworks.com/laguna/trunk/images/u-boot_nor.bin Laguna> setenv ipaddr <localip> Laguna> setenv ipaddr <serverip> Laguna> tftpboot 0x800000 laguna/u-boot-nor.bin Laguna> erase 0x10000000 +$(filesize) Laguna> cp.b 0x800000 0x10000000 $(filesize) Laguna> reset To update the bootloader for GW2380,GW2382,GW2383 (SPI Flash) from uboot: put latest SPI bootloader on tftp server: http://svn.gateworks.com/laguna/trunk/images/u-boot_spi.bin Laguna> setenv ipaddr <localip> Laguna> setenv ipaddr <serverip> Laguna> tftpboot 0x800000 laguna/u-boot-spi.bin Laguna> erase 0x60000000 +$(filesize) Laguna> cp.b 0x800000 0x60000000 $(filesize) Laguna> reset Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 38703
Diffstat (limited to 'target/linux/cns3xxx')
-rw-r--r--target/linux/cns3xxx/image/Makefile42
1 files changed, 16 insertions, 26 deletions
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index 7fa0b35e06..639af35be7 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -7,26 +7,20 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define mkimage
- mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage-$(1)
-endef
-
define Image/Prepare
- $(call mkimage,old,0x00008000)
- $(call mkimage,new,0x20008000)
+ mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage
endef
# Build sysupgrade image
define BuildFirmware/Generic
- dd if=$(KDIR)/uImage-old of=$(KDIR)/uImage-old.pad bs=64k conv=sync; \
- dd if=$(KDIR)/uImage-new of=$(KDIR)/uImage-new.pad bs=64k conv=sync; \
+ dd if=$(KDIR)/uImage of=$(KDIR)/uImage.pad bs=64k conv=sync; \
dd if=$(KDIR)/root.$(1) of=$(KDIR)/root.$(1).pad bs=128k conv=sync; \
sh $(TOPDIR)/scripts/combined-image.sh \
- $(KDIR)/uImage-old.pad \
+ $(KDIR)/uImage.pad \
$(KDIR)/root.$(1).pad \
- $(BIN_DIR)/$(IMG_PREFIX)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))-old-uboot-sysupgrade.bin
+ $(BIN_DIR)/$(IMG_PREFIX)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))-uboot-sysupgrade.bin
sh $(TOPDIR)/scripts/combined-image.sh \
- $(KDIR)/uImage-new.pad \
+ $(KDIR)/uImage.pad \
$(KDIR)/root.$(1).pad \
$(BIN_DIR)/$(IMG_PREFIX)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))-sysupgrade.bin
endef
@@ -34,40 +28,36 @@ endef
define Image/Build
$(call Image/Build/$(1),$(1))
$(call BuildFirmware/Generic,$(1))
+ cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
( \
- dd if=$(KDIR)/uImage-old bs=2048k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-old-uboot-$(1).bin
- ( \
- dd if=$(KDIR)/uImage-new bs=2048k conv=sync; \
+ dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).bin
endef
define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
( \
- dd if=$(KDIR)/uImage-old bs=2048k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-old-uboot-$(1).bin
- ( \
- dd if=$(KDIR)/uImage-new bs=2048k conv=sync; \
+ dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).bin
endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
( \
- dd if=$(KDIR)/uImage-old bs=2048k conv=sync; \
+ dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-old-uboot-$(1).bin
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1)_laguna_nor.bin
( \
- dd if=$(KDIR)/uImage-new bs=2048k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).bin
+ dd if=$(KDIR)/uImage bs=1536k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1)_laguna_spi.bin
endef
$(eval $(call BuildImage))