summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.8/085-ethernet_support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-09 18:51:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-09 18:51:46 +0000
commit95f14d052a7439c60e35a6d910d6bd3de023907c (patch)
tree83b1039c3c9d0ff8d8b842d1ec5fc4a392a3a7d2 /target/linux/cns3xxx/patches-3.8/085-ethernet_support.patch
parent85348d602e2c4b383fa0bec95fb97d9d79094743 (diff)
downloadmaster-31e0f0ae-95f14d052a7439c60e35a6d910d6bd3de023907c.tar.gz
master-31e0f0ae-95f14d052a7439c60e35a6d910d6bd3de023907c.tar.bz2
master-31e0f0ae-95f14d052a7439c60e35a6d910d6bd3de023907c.zip
cns3xxx: add linux 3.8 support and use it by default
SVN-Revision: 35908
Diffstat (limited to 'target/linux/cns3xxx/patches-3.8/085-ethernet_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.8/085-ethernet_support.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/patches-3.8/085-ethernet_support.patch b/target/linux/cns3xxx/patches-3.8/085-ethernet_support.patch
new file mode 100644
index 0000000000..84548a322c
--- /dev/null
+++ b/target/linux/cns3xxx/patches-3.8/085-ethernet_support.patch
@@ -0,0 +1,20 @@
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -32,6 +32,7 @@ source "drivers/net/ethernet/calxeda/Kco
+ source "drivers/net/ethernet/chelsio/Kconfig"
+ source "drivers/net/ethernet/cirrus/Kconfig"
+ source "drivers/net/ethernet/cisco/Kconfig"
++source "drivers/net/ethernet/cavium/Kconfig"
+ source "drivers/net/ethernet/davicom/Kconfig"
+
+ config DNET
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_NET_BFIN) += adi/
+ obj-$(CONFIG_NET_VENDOR_BROADCOM) += broadcom/
+ obj-$(CONFIG_NET_VENDOR_BROCADE) += brocade/
+ obj-$(CONFIG_NET_CALXEDA_XGMAC) += calxeda/
++obj-$(CONFIG_NET_VENDOR_CAVIUM) += cavium/
+ obj-$(CONFIG_NET_VENDOR_CHELSIO) += chelsio/
+ obj-$(CONFIG_NET_VENDOR_CIRRUS) += cirrus/
+ obj-$(CONFIG_NET_VENDOR_CISCO) += cisco/