summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.14/025-smp_support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-11-26 18:01:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-11-26 18:01:29 +0000
commit211669da3b1ca89da78afd32a7012c41958cc378 (patch)
tree6ef0925b47bd06799bacd0ec9752f93bd050b545 /target/linux/cns3xxx/patches-3.14/025-smp_support.patch
parent0525ffa4c5faaa0214b40c6b80a06c8a2567cc62 (diff)
downloadmaster-31e0f0ae-211669da3b1ca89da78afd32a7012c41958cc378.tar.gz
master-31e0f0ae-211669da3b1ca89da78afd32a7012c41958cc378.tar.bz2
master-31e0f0ae-211669da3b1ca89da78afd32a7012c41958cc378.zip
cns3xxx: update to linux 3.14
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43397
Diffstat (limited to 'target/linux/cns3xxx/patches-3.14/025-smp_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.14/025-smp_support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/patches-3.14/025-smp_support.patch b/target/linux/cns3xxx/patches-3.14/025-smp_support.patch
new file mode 100644
index 0000000000..d4ae6f4b9d
--- /dev/null
+++ b/target/linux/cns3xxx/patches-3.14/025-smp_support.patch
@@ -0,0 +1,30 @@
+--- a/arch/arm/mach-cns3xxx/Makefile
++++ b/arch/arm/mach-cns3xxx/Makefile
+@@ -5,3 +5,5 @@ cns3xxx-y += core.o pm.o
+ cns3xxx-$(CONFIG_ATAGS) += devices.o
+ cns3xxx-$(CONFIG_PCI) += pcie.o
+ cns3xxx-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
++cns3xxx-$(CONFIG_SMP) += platsmp.o headsmp.o
++cns3xxx-$(CONFIG_HOTPLUG_CPU) += hotplug.o
+--- a/arch/arm/mach-cns3xxx/Kconfig
++++ b/arch/arm/mach-cns3xxx/Kconfig
+@@ -6,6 +6,9 @@ config ARCH_CNS3XXX
+ select MIGHT_HAVE_CACHE_L2X0
+ select MIGHT_HAVE_PCI
+ select PCI_DOMAINS if PCI
++ select HAVE_ARM_SCU if SMP
++ select HAVE_ARM_TWD if LOCAL_TIMERS
++ select HAVE_SMP
+ help
+ Support for Cavium Networks CNS3XXX platform.
+
+--- a/arch/arm/mach-cns3xxx/core.h
++++ b/arch/arm/mach-cns3xxx/core.h
+@@ -13,6 +13,7 @@
+
+ #include <linux/reboot.h>
+
++extern struct smp_operations cns3xxx_smp_ops;
+ extern void cns3xxx_timer_init(void);
+
+ #ifdef CONFIG_CACHE_L2X0