summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-07 23:24:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-07 23:24:02 +0000
commite5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c (patch)
tree588d7c260fbee8d163a9a93013bb20837bd30df5 /target/linux/cns3xxx/image
parent68449e2e01a434ed03f52261b5502d9c09fdc009 (diff)
downloadmaster-31e0f0ae-e5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c.tar.gz
master-31e0f0ae-e5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c.tar.bz2
master-31e0f0ae-e5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c.zip
cns3xxx: add sysupgrade support
Signed-off-by: Tim Harvey <tharvey@gateworks.com> target/linux/cns3xxx/base-files/lib/cns3xxx.sh | 22 ++ target/linux/cns3xxx/base-files/lib/upgrade/platform.sh | 122 ++++++++++++++++ target/linux/cns3xxx/image/Makefile | 19 +- 3 files changed, 159 insertions(+), 4 deletions(-) SVN-Revision: 33650
Diffstat (limited to 'target/linux/cns3xxx/image')
-rw-r--r--target/linux/cns3xxx/image/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index 271d5ea198..05a0f4f7a1 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -21,21 +21,32 @@ define Image/BuildKernel
cp $(KDIR)/uImage-new $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
+# Build sysupgrade image
+define BuildFirmware/Generic
+ dd if=$(BIN_DIR)/openwrt-$(BOARD)-uImage of=$(KDIR)/uImage.pad bs=64k conv=sync; \
+ dd if=$(KDIR)/root.$(1) of=$(KDIR)/root.$(1).pad bs=128k conv=sync; \
+ sh $(TOPDIR)/scripts/combined-image.sh \
+ $(KDIR)/uImage.pad \
+ $(KDIR)/root.$(1).pad \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))-sysupgrade.bin
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
+ $(call BuildFirmware/Generic,$(1))
endef
define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
endef
define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+ $(call prepare_generic_squashfs,$(KDIR)/root.$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
endef
$(eval $(call BuildImage))