summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-07-21 11:20:53 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-07-21 11:20:53 +0000
commita1cdb24a3bd55a1ef90799ee10e04d67fc36dc71 (patch)
treec4f82e97c24be4bf8139d143e40e4ea93f34b19a /target/linux/cns3xxx/image
parente9924b427eda788b18a45b68b62ea7fca6611e8f (diff)
downloadmaster-31e0f0ae-a1cdb24a3bd55a1ef90799ee10e04d67fc36dc71.tar.gz
master-31e0f0ae-a1cdb24a3bd55a1ef90799ee10e04d67fc36dc71.tar.bz2
master-31e0f0ae-a1cdb24a3bd55a1ef90799ee10e04d67fc36dc71.zip
add support for the Gateworks Laguna family (Cavium Networks Econa CNS3xxx)
SVN-Revision: 22323
Diffstat (limited to 'target/linux/cns3xxx/image')
-rw-r--r--target/linux/cns3xxx/image/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
new file mode 100644
index 0000000000..0265d7c545
--- /dev/null
+++ b/target/linux/cns3xxx/image/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))