summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/base-files/lib/cns3xxx.sh
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-07 23:24:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-07 23:24:02 +0000
commite5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c (patch)
tree588d7c260fbee8d163a9a93013bb20837bd30df5 /target/linux/cns3xxx/base-files/lib/cns3xxx.sh
parent68449e2e01a434ed03f52261b5502d9c09fdc009 (diff)
downloadmaster-31e0f0ae-e5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c.tar.gz
master-31e0f0ae-e5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c.tar.bz2
master-31e0f0ae-e5bb1a1bc7d4ccc5bab9bc759cb3f9665e36194c.zip
cns3xxx: add sysupgrade support
Signed-off-by: Tim Harvey <tharvey@gateworks.com> target/linux/cns3xxx/base-files/lib/cns3xxx.sh | 22 ++ target/linux/cns3xxx/base-files/lib/upgrade/platform.sh | 122 ++++++++++++++++ target/linux/cns3xxx/image/Makefile | 19 +- 3 files changed, 159 insertions(+), 4 deletions(-) SVN-Revision: 33650
Diffstat (limited to 'target/linux/cns3xxx/base-files/lib/cns3xxx.sh')
-rw-r--r--target/linux/cns3xxx/base-files/lib/cns3xxx.sh22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/base-files/lib/cns3xxx.sh b/target/linux/cns3xxx/base-files/lib/cns3xxx.sh
new file mode 100644
index 0000000000..d446777c02
--- /dev/null
+++ b/target/linux/cns3xxx/base-files/lib/cns3xxx.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+cns3xxx_board_name() {
+ local machine
+ local name
+
+ machine=$(awk 'BEGIN{FS="[ \t]+:[ \t]"} /Hardware/ {print $2}' /proc/cpuinfo)
+
+ case "$machine" in
+ "Gateworks Corporation Laguna"*)
+ name="laguna"
+ ;;
+ *)
+ name="generic";
+ ;;
+ esac
+
+ echo $name
+}