summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-07-21 11:20:53 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-07-21 11:20:53 +0000
commita1cdb24a3bd55a1ef90799ee10e04d67fc36dc71 (patch)
treec4f82e97c24be4bf8139d143e40e4ea93f34b19a /target/linux/cns3xxx/Makefile
parente9924b427eda788b18a45b68b62ea7fca6611e8f (diff)
downloadmaster-31e0f0ae-a1cdb24a3bd55a1ef90799ee10e04d67fc36dc71.tar.gz
master-31e0f0ae-a1cdb24a3bd55a1ef90799ee10e04d67fc36dc71.tar.bz2
master-31e0f0ae-a1cdb24a3bd55a1ef90799ee10e04d67fc36dc71.zip
add support for the Gateworks Laguna family (Cavium Networks Econa CNS3xxx)
SVN-Revision: 22323
Diffstat (limited to 'target/linux/cns3xxx/Makefile')
-rw-r--r--target/linux/cns3xxx/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/Makefile b/target/linux/cns3xxx/Makefile
new file mode 100644
index 0000000000..45faa103c1
--- /dev/null
+++ b/target/linux/cns3xxx/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=cns3xxx
+BOARDNAME:=Cavium Networks Econa CNS3xxx
+FEATURES:=squashfs fpu gpio
+CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
+
+LINUX_VERSION:=2.6.31.14
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for Cavium Networks Econa CNS3xxx based boards,
+ eg. the Gateworks Laguna family
+endef
+
+KERNELNAME:="uImage"
+
+$(eval $(call BuildTarget))