summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-31 13:17:44 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-31 13:17:51 +0200
commitdf68d6eb15bfb3abe97c4048e57bd5192d796edb (patch)
tree0f1c25e8dcc8ee92842ee8fb87d7a8c89e8e28b2 /target/linux/brcm63xx
parent62d4665551000b3c85077c48d059a2c796dffc68 (diff)
downloadmaster-31e0f0ae-df68d6eb15bfb3abe97c4048e57bd5192d796edb.tar.gz
master-31e0f0ae-df68d6eb15bfb3abe97c4048e57bd5192d796edb.tar.bz2
master-31e0f0ae-df68d6eb15bfb3abe97c4048e57bd5192d796edb.zip
brcm63xx: fix build with per-device rootfs
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index ca1792abf0..f5de6734fe 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -98,7 +98,7 @@ $(shell expr substr "$(1)" 1 16)
endef
define Image/FileSystemStrip
-$(subst root.,,$(notdir $(1)))
+$(firstword $(subst +,$(space),$(subst root.,,$(notdir $(1)))))
endef
define Build/cfe-bin