summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@lairdtech.com>2016-06-17 15:00:17 +0100
committerJohn Crispin <john@phrozen.org>2016-06-22 19:32:06 +0200
commitb7baaaf782f40bf6a1d017a1f41480b6229a12c9 (patch)
tree9b6969fd16d1ca63c61cdbfbe75a5bfeb1d25127 /target/linux/brcm63xx
parent7385f754b1a1562869ddf6a561f70623d626ed6b (diff)
downloadmaster-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.gz
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.bz2
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.zip
kernel: Move append-dtb to common image-commands
This build step is used by various targets, move it to a common section. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index d2a381431d..2c82c34363 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -34,11 +34,6 @@ define Build/Compile
endef
### Kernel scripts ###
-define Build/append-dtb
- $(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb)
- cat $@.dtb >> $@
-endef
-
define Build/hcs-initramfs
$(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_bytes=$(HCS_MAGIC_BYTES) \
--rev_maj=$(HCS_REV_MAJ) --rev_min=$(HCS_REV_MIN) --input_file=$@ \
@@ -171,8 +166,9 @@ define Device/Default
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_SUFFIX := .elf
DEVICE_DTS :=
+ DEVICE_DTS_DIR := ../dts
endef
-DEVICE_VARS += DEVICE_DTS
+DEVICE_VARS += DEVICE_DTS DEVICE_DTS_DIR
ATH5K_PACKAGES := kmod-ath5k wpad-mini
ATH9K_PACKAGES := kmod-ath9k wpad-mini