summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2016-01-24 12:36:10 +0000
committerJonas Gorski <jogo@openwrt.org>2016-01-24 12:36:10 +0000
commit065a240345e83f3610c4a52dace6bac4e0d4b8ae (patch)
tree7090b4ea1fca93c935fcc554c65a2a8881c61761 /target/linux/brcm63xx
parenta9b4952be143b67c929066fc67fc50d8fe5f64b5 (diff)
downloadmaster-31e0f0ae-065a240345e83f3610c4a52dace6bac4e0d4b8ae.tar.gz
master-31e0f0ae-065a240345e83f3610c4a52dace6bac4e0d4b8ae.tar.bz2
master-31e0f0ae-065a240345e83f3610c4a52dace6bac4e0d4b8ae.zip
brcm63xx: fix build of lzma-loader with binutils 2.25.1
Apply the same fix as ar71xx needed in r46893. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 48473
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/lzma-loader/src/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/lzma-loader/src/Makefile b/target/linux/brcm63xx/image/lzma-loader/src/Makefile
index 50c22d8b29..167bf6455a 100644
--- a/target/linux/brcm63xx/image/lzma-loader/src/Makefile
+++ b/target/linux/brcm63xx/image/lzma-loader/src/Makefile
@@ -24,7 +24,8 @@ LD := $(CROSS_COMPILE)ld
OBJCOPY := $(CROSS_COMPILE)objcopy
OBJDUMP := $(CROSS_COMPILE)objdump
-BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+ -R .MIPS.abiflags -S
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \