summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-05-09 17:08:51 +0000
committerNicolas Thill <nico@openwrt.org>2008-05-09 17:08:51 +0000
commite3a42b23c6dacca7b8f58d125030ff0922ce0a4b (patch)
tree31c63bba02c9a0100b1cde13bdcdb64fc332f298 /target/linux/brcm63xx
parent9b3eedabdb25e25316d3700e19c9186fb41417b5 (diff)
downloadmaster-31e0f0ae-e3a42b23c6dacca7b8f58d125030ff0922ce0a4b.tar.gz
master-31e0f0ae-e3a42b23c6dacca7b8f58d125030ff0922ce0a4b.tar.bz2
master-31e0f0ae-e3a42b23c6dacca7b8f58d125030ff0922ce0a4b.zip
enable proper PCI & USB support detection at config-time by disabling CONFIG_PCI & CONFIG_USB entries in generic/config and enabling them on targets where appropriate
SVN-Revision: 11097
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/config-2.6.242
-rw-r--r--target/linux/brcm63xx/image/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/config-2.6.24 b/target/linux/brcm63xx/config-2.6.24
index 179d32278f..92c4a4f0a5 100644
--- a/target/linux/brcm63xx/config-2.6.24
+++ b/target/linux/brcm63xx/config-2.6.24
@@ -214,6 +214,7 @@ CONFIG_PAGE_SIZE_4KB=y
# CONFIG_PAGE_SIZE_8KB is not set
CONFIG_PCCARD=m
CONFIG_PCCARD_NONSTATIC=m
+CONFIG_PCI=y
CONFIG_PCI_DOMAINS=y
CONFIG_PHYLIB=m
# CONFIG_PMC_MSP is not set
@@ -283,6 +284,7 @@ CONFIG_TIPC=m
# CONFIG_TOSHIBA_RBTX4927 is not set
# CONFIG_TOSHIBA_RBTX4938 is not set
CONFIG_TRAD_SIGNALS=y
+CONFIG_USB=m
# CONFIG_USB_EHCI_HCD is not set
# CONFIG_USB_R8A66597_HCD is not set
# CONFIG_USB_SERIAL_CH341 is not set
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index fab73efd20..16c57cae4f 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -45,9 +45,7 @@ define Image/Prepare
endef
define Image/Build
-ifneq($(1),ext2)
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
-endif
endef
$(eval $(call BuildImage))